En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés. Mentions légales.

Blog / Nouvelles - Logiciel


Information importante concernant l'envoi de mails via DipiLanAlert...  

Durant le développement de DipiLanAlert j'ai été confronté à des problèmes d'envoi de mails en utilisant une configuration SMTP sécurisée (case à cocher "Utiliser SSL"). J'avais fini par trouver une explication mais j'ai oublié d'évoquer le sujet dans le manuel de l'application. Oups !

Et aujourd'hui, quand un utilisateur m'a contacté pour me signaler des erreurs lors de l'envoi des mails (avec la même configuration SMTP que celle utilisée dans LanAlertCenter), je n'ai pas percuté tout de suite.

Après une bonne heure à essayer de comprendre, la mémoire m'est enfin revenue : la méthode d'envoi de mails du Framework .NET n'utilise pas SMTP/SSL (port 465) mais STARTTLS/SSL, donc le port 587 ! Si vous êtes curieux, je vous invite à lire ceci.

Dans la prochaine version je ferai en sorte que l'activation de la case à cocher "Utiliser SSL" propose par défaut le port 587 au lieu du 465. Et j'ajouterai cette petite explication dans le manuel que personne ne lit.

Désolé pour le désagrément.

smile

Durant le développement de DipiLanAlert j'ai été confronté à des problèmes d'envoi de mails en utilisant une configuration SMTP sécurisée (case à cocher "Utiliser SSL"). J'avais fini par trouver une explication mais j'ai oublié d'évoquer le sujet dans le manuel de l'application. Oups !

Et aujourd'hui, quand un utilisateur m'a contacté pour me signaler des erreurs lors de l'envoi des mails (avec la même configuration SMTP que celle utilisée dans LanAlertCenter), je n'ai pas percuté tout de suite.

Après une bonne heure à essayer de comprendre, la mémoire m'est enfin revenue : la méthode d'envoi de mails du Framework .NET n'utilise pas SMTP/SSL (port 465) mais STARTTLS/SSL, donc le port 587 ! Si vous êtes curieux, je vous invite à lire ceci.

Dans la prochaine version je ferai en sorte que l'activation de la case à cocher "Utiliser SSL" propose par défaut le port 587 au lieu du 465. Et j'ajouterai cette petite explication dans le manuel que personne ne lit.

Désolé pour le désagrément.

smile

Fermer

Publié le 07/10/2020 @ 20:21   | |


Commentaires

Personne n'a encore laissé de commentaire.
Soyez donc le premier !