En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés.
Mentions légales.

SendMail // Envoi de mails doté d'un mode 'scriptable'

sendmail01.pngsendmail02.png
français anglais allemand   (pour contribuer, rendez-vous sur la page des fichiers de langues)

Avec un tel nom, il n'est pas bien difficile d'imaginer la fonction principale de SendMail... Mais cet outil est bien plus qu'un simple logiciel d'envoi de mails !

Une des principales caractéristiques de SendMail est qu'il peut être utilisé soit en mode interface graphique, soit en mode script. Je suppose qu'il n'est pas utile que je m'étende sur le premier, le second nécessite en revanche quelques explications : SendMail est "scriptable", ce qui signifie que l'on peut aussi l'utiliser en mode "ligne de commande", grâce à une syntaxe complexe.

Il est par conséquent possible d'utiliser SendMail en complément d'autres outils qui permettent d'exécuter des traitements externes. C'est le cas de LanAlertCenter (que vous pouvez aussi trouver sur ce site) mais aussi de nombreux outils du commerce, dans divers domaines.

Codes erreurs (ErrorLevel) retournés lors de l'utilisation en mode ligne de commande :

  • 0 : message envoyé avec succès
  • 1 : erreur dans les paramètres passés par l'utilisateur
  • 2 : erreur d'accès à l'ActiveDirectory
  • 3 : erreur de destinataire (groupes vides)
  • 4 : erreur de pièce jointe (introuvable)
  • 5 : erreur d'envoi du message (OSSMTP)

Une autre particularité de cet outil est qu'il permet d'envoyer des mails soit à des destinataires désignés manuellement, soit aux membres de groupes globaux de l'ActiveDirectory. Cette dernière possibilité est pratique puisqu'elle peut ainsi éviter d'avoir recours à la création de listes de distribution.

Cet outil n'aurait pas été complet s'il n'avait pas permis à l'utilisateur de pouvoir joindre des fichiers, cette fonctionnalité est par conséquent présente !

Enfin, je tiens à préciser que SendMail utilise le composant OSSMTP développé par OstroSoft que je remercie vivement.

ATTENTIONcet outil ne doit pas être utilisé pour effectuer du spam !

Télécharger Télécharger ce logiciel (version installeur)
Télécharger Télécharger ce logiciel (version portable ZIP) Note importante aux utilisateurs des versions portables

Date de création : 21/02/2005 @ 14:26
Dernière modification : 06/07/2020 @ 18:32
Catégorie : - Aide à l'administration
Page lue 147902 fois
 

Réactions à cet article

Réaction n°84 

par   ingrid le 25/07/2012 @ 14:57

Bonjour,

Tout d'abord merci pour cet utilitaire très pratique.

J'ai juste une petite remarque; j'ai installé la version 2.0 et fais un test d'envoi de mail par l'interface graphique; tout est ok. Lorsque je fais le même test en ligne de commande, le mail se retrouve dans courrier indésirable de outlook. J'ai donc installé la version 2.1 et le problème existe encore et également lors d'un envoi par l'interface graphique.

Y'a-t-il un paramètre spécifique à ne pas oublier ?

[réponse de damien, le 25/07/2012 à 15h15]

Je viens de faire le double test (via ligne de commande et via interface), vers une de mes boites FREE, avec "bonjour" dans l'objet ainsi que dans le corps du message et je ne constate pas ce problème.

Peux-tu m'en dire plus sur ce que tu as utilisé comme valeurs ? Une copie d'écran de l'interface et la ligne de commande utilisée seraient les bienvenues stp.

Par contre, à l'occasion de ces tests je me suis aperçu d'un bug qui occasionne un méchant plantage de l'appli en mode interface : il se produit quand on clique sur le bouton "flèche vers le bas" situé à droite d'une des lignes de destinataires et que l'on "referme" le menu contextuel ainsi ouvert en cliquant sur le même bouton sans n'avoir sélectionné aucun de ses éléments... J'essaye de corriger ça au plus tôt.

[réponse complémentaire de damien, le 25/07/2012 à 17h38]

Bug corrigé dans la v2.1.1 qui est disponible depuis quelques minutes !


Réaction n°83 

par   clement le 28/06/2012 @ 11:37

Bonjour,

Votre outil est génial pour l'utilisation que j'en fais => utilisation dans un batch pour renvoyer un compte rendu en pièce jointe.

J'ai cependant 2 questions :
- l'option /r permet de faire l'accusé de réception et est fiable ?
- Y-a-t'il une option pour envoyer en copie (cc) ?

Cordialement,

Clément

[réponse de damien, le 28/06/2012 à 18h22]

Pour les "accuser de réception" c'est /ar et non /r. Il y a aussi /al pour les "accuser de lecture" et /arl pour les "accuser de réception/lecture".

Pour ce qui est de la fiabilité, rien n'est garanti car cela dépend du client de messagerie du destinataire. Certains gèrent les "accuser de lecture", d'autres non. Enfin, certains offrent même la possibilité à l'utilisateur de choisir si oui ou non il souhaite accuser réception (pour les messages qui le demandent).

Enfin, pour répondre à ta dernière question : c'est l'option /c qu'il faut utiliser pour mettre un destinataire en copie, et tu peux aussi mettre quelqu'un en copie cachée à l'aide de /cc. Exemple :

sendmail.exe /a:destinataire@free.fr /c:"copie1@free.fr, copie2@free.fr" /cc:copie_cachée@free.fr" /o:"Message de test" /ct:"Bonjour,§§Au revoir !"

Pour mémoire, les "§" dans le paramètre /ct sont transformés en retour-chariot...


Réaction n°82 

par   Landry le 19/06/2012 @ 03:29

Bonjour,Le produit marche très bien mais il ne récupère pas le fuseau horaire du poste sur lequel il est lancé lors de l'envoi du mail.Exemple d'un mail envoyé à 12h16 d'un PC paramétré à GMT+11 qui s'affiche dans Outlook avec la mention "envoyé: mar. 19/06/2012 23:17" soit cet après-midi...  cligneReceived: from XXX (XXX) by XXX (XXX) with Microsoft SMTP Server id XXX; Tue, 19 Jun 2012 12:16:02 +1100From: XXXTo: XXXSubject: TEST DIPI SOFTDate: Tue, 19 Jun 2012 12:16:02 +0000Auriez-vous une solution à me proposer pour régler ce problème ?Merci d'avance de votre réponse.Landry

[réponse de damien, le 19/06/2012 à 06h59]

En fait, je ne touche pas à l'horodatage du message lors de son envoi : je laisse la valeur par défaut car je pensais que dans ce cas, c'était le serveur SMTP qui faisait l'horodatage.

Je vais voir ce que je peux faire pour régler le problème. Recontacte-moi d'ici une semaine si je ne t'ai pas recontacté pour te proposer une version bêta à tester.


Réaction n°81 

par   rafi22 le 18/06/2012 @ 11:00

bonjour,

j'ai le message" impossible de créer l'objet smtp" ou "l'erreur 12004" lors de l'utilisation du logiciel en ligne de commande. Est une erreur de ma part ?

pouvez vous m'aider à regler ce pour ce probleme.

Cordialement.

[réponse de damien, le 18/06/2012 à 11h26]

S'agit-il de la version "installeur" ou de la version "portable" ?

A première vue je pense que c'est la "portable" et que le composant OSSMTP.OCX n'a pas été déclaré dans le registre. As-tu regardé le fichier "Lisez-moi (version portable).txt" qui se trouve dans l'archive ? Ce doc est aussi consultable ici.


Réaction n°80 

par   wolfy1976 le 05/05/2012 @ 13:17

Bonjour, J'utilise sendmail déjà depuis quelques temps. C'est un freeware fort intéressant. J'ai une erreur du type :

Error 12012: SMTP connection failed. Timeout exceeded

lorsque j'essaye d'envoyer des pièces jointes de l'ordre de 5Mo en ligne de commande ou en intéractif avec le stmp d'ORANGE. Avez-vous une idée ?

[réponse de damien, le 09/05/2012 à 14h14]

Je viens de jeter un coup d’œil au code et je remarque que le composant que j'utilise pour l'envoi des mails offre la possibilité de paramétrer le timeout. Sa valeur par défaut est fixée à 10 secondes et je n'y touche pas actuellement. Ce délai est peut-être trop court pour avoir le temps d'envoyer un fichier de cette taille...

Quand tu essayes d'envoyer la même pièce jointe (ou un fichier de taille comparable) avec Outlook, Thunderbird ou quelque autre client de messagerie configuré de la même façon, combien de temps cela met-il environ ?

J'essaye de te préparer une bêta permettant d'intervenir sur ce paramètre... relance-moi d'ici quelques jours si je tarde à te recontacter.

PS.: Bizarrement je n'ai pas reçu de notification par mail de ta question, que je découvre à l'instant, en répondant à d'autres utilisateurs.


Réaction n°79 

par   malko06 le 13/04/2012 @ 12:00

Enfin et très bien fait chapeau et merci !

Je peux enfin faire ce que je voulais cligne J'apporte quelques infos. sur l'utilisation de différents points :

Code HTML dans le corps du message :

Pas de gestion des "style type" donc ceci ne passe pas :<style type="text/css">.style1 { color: #FF0000;}</style><h1 class="style1">Votre texte</h1>
Il faudra donc préférer un :<h1 style="color: #FF0000">Votre texte </h1>
Ca sous entend donc de le faire "à l'ancienne" sourire En utilisation ligne de commande il faut utiliser ch ou chf pour le "mélange" texte et HTML. Ce n'est pas précisé, semble une évidence mais ça fera peut être gagner du temps à certains.
 

Expéditeur / Réponse / Authentification : qui est qui ?
Lorsque l'on utilise une authentification, il faut simplement que le compte soit existant. Il est donc possible d'utiliser une adresse générique existante et de renseigner le login/password et éventuellement le serveur pop (selon la méthode utilisée). Ce n'est en rien un élément visible par le lecteur standard.
Par contre l'expéditeur est l'adresse mail qui aura la réponse en cas d'accusé de réception/lecture. Si vous gérer ceci, elle doit donc elle aussi exister.
L'adresse de réponse ne sert donc qu'en réponse standard au mail et non en réponse à l'accusé de lecture/réception.

Cordialement

[réponse de damien]

Merci pour ces éléments qui pourront effectivement être utiles à d'autres. C'est beau le partage ! cligne

PS.: je duplique ton commentaire ici où il aura plus de chances d'être lu qu'en réaction d'un billet du blog...


Réaction n°78 

par   Remy le 21/03/2012 @ 12:09

Bonjour,Merci pour la mise à jour du logiciel, une question quand meme : j'utilise sendmail en ligne de commande + tache planifée pour m'envoyer le rapport du wol chaque matin.Ma tache planifiée ne se termine pas car je ne valide pas la fenetre qui m'informe que le mail est bien parti. Y a t'il un argument a rajouter ? merci d'avance pour la réponse

[réponse de damien, le 21/03/2012 à 12h18]

Oui, il suffit d'ajouter un /l (L minuscule) pour diriger l'information dans le fichier log. Autre possibilité : utiliser un /r qui permet de recevoir les notifications par mail (à l'expéditeur désigné) en cas d'erreur...

[réponse complémentaire de damien, le 21/03/2012 à 18h39]

Je viens de regarder le code à nouveau et le /r ne génère pas un envoi de mail uniquement en cas d'erreur : il le fait systématiquement même pour les messages envoyés avec succès... Désolé.


Réaction n°77 

par PK1157 le 18/03/2012 @ 22:34

Merci beaucoup pour la réactivité !

[réponse de damien, le 19/03/2012 à 06h59]

C'est normal, je ne fais qu'assurer le SAV !


Réaction n°76 

par   PK1157 le 18/03/2012 @ 19:59

Bonjour,
J'ai téléchargé et installé cet après-midi SenMail.

Lors de l'installation, AVIRA Free Antivirus s'est affolé et m'a signalé que le fichier sendmail200.exe contenait la signature d'un logiciel malveillant : SPR/PSW.Messen.O

S'agit-il d'un "faux positif"ou d'une vraie raison d'inquiétude ?
Cordialement,
PK1157

[réponse de damien, le 18/03/2012 à 20h15]

La machine sur laquelle je développe et je construis les packages est protégée par Nod32 qui ne détecte rien. Je pense que c'est la présence du composant OSSMTP.ocx (que j'utilise pour l'envoi des mails) dans l'archive qui génère l'alerte. Pas de problème, tous les fichiers sont sains, tu peux installer sans crainte.

J'ai quand même soumis le fichier SendMail200.exe sur le site VirusTotal qui l'a testé sur 43 antivirus : voici le résultat de l'analyse, seul Antivir remonte une alerte effectivement.


Réaction n°75 

par unegargouille le 24/11/2011 @ 20:10

bonjour encore merci pour ce super logiciel.

J'utilise sendmail 2.0 beta 5

J'ai essayé de l'installer sur mon serveur Windows Server 2003 mais lorsque je fais un test d'envoi en manuel, j'ai une erreur : "erreur d'execution 430 - la classe ne gère pas Automation"

Il fonctionne très bien sur mon PC de bureau sous Seven 64.

J'ai pas trouvé la cause.  déconcerté

[réponse de damien, le 24/11/2011 à 20h25]

Ça ressemble au composant ossmtp.dll qui n'est pas reconnu. Comment as-tu procédé pour l'installation sur ton serveur ? Il faut commencer par installer la version publiée (v1.8) puis écraser l'exécutable par celui inclus dans le .zip de la v2 bêta 5 (d'ailleurs, la dernière bêta est la bêta 8 cligne).