SendMail // Envoi de mails doté d'un mode 'scriptable'

sendmail01.pngsendmail02.png
français anglais allemand   (pour contribuer, rendez-vous sur la page des fichiers de langues)

Avec un tel nom, il n'est pas bien difficile d'imaginer la fonction principale de SendMail... Mais cet outil est bien plus qu'un simple logiciel d'envoi de mails !

Une des principales caractéristiques de SendMail est qu'il peut être utilisé soit en mode interface graphique, soit en mode script. Je suppose qu'il n'est pas utile que je m'étende sur le premier, le second nécessite en revanche quelques explications : SendMail est "scriptable", ce qui signifie que l'on peut aussi l'utiliser en mode "ligne de commande", grâce à une syntaxe complexe.

Il est par conséquent possible d'utiliser SendMail en complément d'autres outils qui permettent d'exécuter des traitements externes. C'est le cas de LanAlertCenter (que vous pouvez aussi trouver sur ce site) mais aussi de nombreux outils du commerce, dans divers domaines.

Codes erreurs (ErrorLevel) retournés lors de l'utilisation en mode ligne de commande :

  • 0 : message envoyé avec succès
  • 1 : erreur dans les paramètres passés par l'utilisateur
  • 2 : erreur d'accès à l'ActiveDirectory
  • 3 : erreur de destinataire (groupes vides)
  • 4 : erreur de pièce jointe (introuvable)
  • 5 : erreur d'envoi du message (OSSMTP)

Une autre particularité de cet outil est qu'il permet d'envoyer des mails soit à des destinataires désignés manuellement, soit aux membres de groupes globaux de l'ActiveDirectory. Cette dernière possibilité est pratique puisqu'elle peut ainsi éviter d'avoir recours à la création de listes de distribution.

Cet outil n'aurait pas été complet s'il n'avait pas permis à l'utilisateur de pouvoir joindre des fichiers, cette fonctionnalité est par conséquent présente !

Enfin, je tiens à préciser que SendMail utilise le composant OSSMTP développé par OstroSoft que je remercie vivement.

ATTENTIONcet outil ne doit pas être utilisé pour effectuer du spam !

Télécharger Télécharger ce logiciel (version installeur)
Télécharger Télécharger ce logiciel (version portable ZIP) Note importante aux utilisateurs des versions portables

Date de création : 21/02/2005 @ 14:26
Dernière modification : 06/07/2020 @ 18:32
Catégorie : - Aide à l'administration
Page lue 156312 fois
 

Réactions à cet article

Réaction n°37 

par Olivier le 21/05/2009 @ 02:00

Je trouve que Sendmail est un super outil !

Je l'utilise en mode batch à l'aide d'une application access qui se lance en automatique tous les matins par une tache plannifiée

L'application Access contient des tables liès à ma base de données Sybase de mon ERP. Cette application récupère certaines données et mets en forme des mails qui sont envoyés à certaines personnes de mon entreprise.

Grace à ce petit developpement mon travail de controle au sein de mon entreprise me prend beaucoup moins de temps qu'auparavant.

Il est dommage qu'on ne puisse pas inclure une image dans le corps du mail.En effet pour envoyer une image nous sommes obligé de la joindre dans un fichier. Peut-etre que cela sera disponible dans une prochaine version ?

Ce serait tres pratique pour envoyer des publicités ou de faire une eventuelle action commerciale.

Si vous avez une solution, merci de m'en faire part.

A+

Olivier

[réponse de damien, le 21/05/2009 à 09h10]

Merci de nous faire part de ton retour d'expérience, je suis toujours friand d'informations sur la façon dont mes outils peuvent être mis en œuvre par les utilisateurs.

La version actuelle ne permet effectivement pas de joindre des images dans le corps du message car le mail est envoyé au format text. J'ai commencé il y a plusieurs mois à travailler sur la prochaine version (qui permettra de choisir entre text/html voire même les deux formats en même temps) mais j'ai du la mettre en attente car j'avais en parallèle entrepris des modifs sur d'autres outils.

C'est assez difficile d'avoir tant de softs à gérer... surtout quand cette activité est à conjuguer avec une vie familiale et un boulot. Bref, autant dire que je n'ai aucune solution immédiate à te proposer, et j'en suis désolé.


Réaction n°36 

par Kev1 le 10/02/2009 @ 13:14

Bonjour a tous et merci d'avance a tous ceux qui prendront le temp de lire ce Post.

J'ai installé recemment cette version de SendMail qui fonctionne avec succes via l'interface fenetrée. Par la suite, je souhaite exécuter l'envoi de mail de maniere automatique a l'aide de taches planifiees...

J'ai donc créer un fichier .bat contenant cette commande qui envoie le mail correctement :

sendmail /u:***** /@:****.fr /s:**** /p:25 /e:*** /t:Pour info /m:test.txt

Le probleme que je rencontre est qu'une fenetre apparait suite a l'envoi de ce mail me demandant de confirmer le message suivant : "Le message 'Pour info' a ete envoye a 1 destinataire(s)...."

En conclusion, si je n'appuie pas sur OK, le mail est tout de meme envoye mais la fenetre quant a elle reste affichee a l'ecran. Y-a-t-il donc un moyen pour ne pas faire apparaitre ce message ?

Je pense que oui car dans le cas contraire je ne vois pas pourquoi on utiliserait l'automatisation de SendMail par ligne de commande...

Merci d'avance pour toutes eventuelles reponses de votre part.

Kev1.

PS : Dsl pour les accents, je suis en Angleterre et suis equipe d'un clavier QWERTY :)

[réponse de damien, le 10/02/2009 à 14h22]

En poussant un peu plus la lecture des réactions des autres utilisateurs, la n°18 par exemple, tu serais tombé sur le paramètre /l (L minuscule). langue

C'est aussi évoqué dans la fenêtre "A propos de" mais je reconnais que ce n'est pas explicite du tout... désolé. oups

PS.: pas de problème pour les accents : tu écris mieux que certains qui causent SMS, et ça ça m'énerve ! portnawak


Réaction n°35 

par Istephane le 10/01/2009 @ 00:07

Bonsoir,

désolé de vous faire passer du temps sur ce pb !!! déconcerté
Alors, j'ai du nouveau de mon côté. J'ai pas mal potassé sur le pb
cette après-midi et je crois que j'ai incriminé un peu trop vite
sendmail !!! faut pas m'en vouloir ! désolé ! cligne
En fait, j'ai l'impression que le pb vient plus du serveur lotus. Tant
que le mail est dans la boite de reception du serveur (la boite de
routage quoi), tout est ok, y compris le nom des fichiers. Par contre,
dès que je le libère pour qu'il aille dans la base utilisateur, il le
renomme à ce moment là.

Je vais regarder si je trouve qq chose à ce niveau. Je vous tiendrai au courant.

En tout cas, vraiment très pratique !!! il y a moyen par contre de ne
pas avoir la fenètre d'indication que le mail à bien été envoyé ?

Cdt
Stéphane

[réponse de damien, le 10/01/2009 à 11h42]

OK, merci pour ta réponse...

Je suis quand même surpris que ça fonctionne correctement en mode GUI (fenêtré)...

Pas de problème pour le temps que j'ai passé, c'est normal que j'assure le SAV, même si mes logiciels sont gratuits.


Réaction n°34 

par Istephane le 09/01/2009 @ 16:37

Bonjour,

J'utilise le logiciel uniquement en ligne de commande et tout fonctionne bien sauf une petite chose : les pièces jointes.

Je recois bien les pieces jointes avec leur contenu (fichier texte avec extensions diverses) mais dans le mail reçu, les noms des fichiers sont remplacés par des noms aléatoires et avec l'extension .dat.

Pour info, en mode fenetré, il n'y a aucun soucis. Donc peut etre juste un paramètre à changer...

Sinon, le logiciel est très pratique et simple, bravo.

Merci pour votre réponse.

[réponse de damien, le 09/01/2009 à 22h42]

Tout d'abord, tu es le premier à me remonter ce problème. J'ai donc fait quelques tests : 1 petite pièce jointe pour commencer, puis 1 plus grosse, puis plusieurs pièces jointes, mais aucune fois je n'ai pas réussi à reproduire le problème... et ce malgré une bonne heure de tests en tous genres.

Peux-tu m'en dire un peu plus sur le contexte de l'utilisation ? Est-ce que ça se produit systématiquement ou ponctuellement ? Quel type de fichier joint ?

Enfin, peux-tu m'envoyer par mail la ligne de commande que tu utilises (ou un .bat par exemple), avec des exemples de fichiers joints qui posent problèmes, ça me ferait gagner du temps... merci d'avance !


Réaction n°33 

par Patrick le 27/08/2008 @ 18:00

Bonjour,

Merci pour ce logiciel qui me permet d'automatiser des envois de mails dans un applicatif spécifique.

Toutefois j'ai un probléme pour les pièces jointes, si la PJ est inférieure à 7 Mo pas de problème, au dessus de cette taille le mail n'est pas réceptionné par le destinataire alors que tout semble s'être passé correctement.

Je suis en ORANGE.SMTP et j'ai l'option GIGA MAIL qui me permet d'échanger des fichiers jusquà  20 Mo , cela fonctionne correctement par OUTLOOK .

Merci pour votre réponse

Patrick

[réponse de damien, le 31/08/2008 à 10h30]

Vous êtes le premier à me rapporter ce problème que je n'ai pas constaté jusqu'alors. Vos tests entre Outlook et mon soft ont-ils été effectués avec le même contenu (corps du message et pièce jointe) ?

Il est possible que le problème vienne du composant que j'utilise (OSSMTP) mais j'en doute : il a depuis longtemps fait ses preuves. Cela peut par contre provenir de votre FAI qui considère peut-être le message comme un spam en voyant OSSMTP dans l'en-tête du mail ?

Je viens de faire quelques tests avec un fichier > 9Mo : il n'est pas arrivé sur mes boites Free car supérieur à la limite de taille imposée (mais j'ai reçu une notification du postmaster dans la boite de l'expéditeur). Un autre test vers une boite Yahoo s'est en revanche révélé positifs.

Donc RAS du côté du composant OSSMTP ou de mon soft... pas ma faute


Réaction n°32 

par Steph le 17/06/2008 @ 13:46

Bonjour,

Merci beaucoup pour votre sympathique logiciel.

J'avoue que j'ai quand même un petit soucis pour le faire fonctionner correctement: lorsque je l'utilise en mode graphique, pas de problèmes, l'envoi des mails se fait correctement.

Lorsque je le fais en mode ligne de commande depuis une fenêtre DOS, pas de problèmes non plus, les mails arrivent correctement à leur destinataire.

En revanche, lorsque j'essaie de l'intégrer à un script Perl, et que la même ligne de commande est passée en faisant un qx($ligne_de_commande), je n'ai aucun message d'erreur, sauf que l'envoi des mails ne se fait pas: ils n'arrivent jamais à leur destinataire.

C'est pareil lorsque je fais un exec($ligne_de_commande) ou un $tmp=`$ligne_de_commande`;

Avez-vous une idée de la raison de ce disfonctionnement ?

J'avoue que cela me rendrait un très grand service de pouvoir automatiser mes envois de mail et j'y arrive pas triste

Merci d'avance pour votre aide,

Stéphane

[réponse de damien, le 17/06/2008 à 14:02]   Attention, cette réponse fait référence à une ancienne syntaxe de SendMail

Alors là, je n'en ai aucune idée : ne connaissant pas du tout Perl je suis bien incapable de vous aider... pas ma faute

Peut-être s'agit-il d'un problème de path ? Y a-t-il un moyen de voir si l'exe s'est bien lancé (gestionnaire de tâches, par exemple) ? Si vous lancez un autre exe que le mien, il se passe quelque chose ?

Si vous pouvez me donner des indications (package, script, etc.) pour monter rapidement un environnement qui me permette de tester ce mode de fonctionnement, je suis preneur... En d'autres termes, aidez-moi à vous aider ! sourire

[réponse complémentaire de damien, le 17/06/2008 à 14h58]

Je viens tout juste d'installer ActivePerl (une version 5.8.8.822 dispo sur Clubic car impossible de télécharger depuis le site officiel) et de tester une ligne de commande toute simple :

perl -e "exec 'sendmail /u:damien@dipisoft.com /t:test /m:message.txt'"

Eh ben ça fonctionne : j'ai bien reçu le message...

Es-tu sur que le fichier de configuration (sendmail.ini) a bien été configuré ?


Réaction n°31 

par Romrik le 08/06/2008 @ 11:44

Bonjour

Cet utilitaire est très utile
Vous dites que le corps en html est prévu
Quand le serait-il ? fin d'année 2008 ? été 2008 ?

Cordialement

[réponse de damien, le 09/06/2008 à 15h00]

Non seulement c'est prévu mais cette fonctionnalité est quasiment prête. Il ne reste qu'à terminer les autres modifs en cours (authentification notamment).

Le problème est que j'ai pas mal d'autres choses en cours sur d'autres softs donc je ne me hasarderai pas à avancer une date... Peut-être le mois de juillet sera-t-il calme et me permettra d'avancer un peu ? Je l'espère. cligne


Réaction n°30 

par Fabien le 08/04/2008 @ 13:46

Bonjour,

Serait-il envisageable de supporter des fichiers html pour alimenter le corps de mail dans une évolution prochaine ou cela restera-t-il réservé à des produits plus "lourds" ?

[réponse de damien, le 08/04/2008 à 15h56]

Non seulement c'est prévu, mais c'est même quasiment développé. De mémoire, il me restait encore quelques petites modifs et des tests à effectuer.

Ça fait un moment que je n'ai pas remis le nez dans cette appli, il va me falloir un peu de temps pour reprendre là où je m'étais arrêté... cligne


Réaction n°29 

par dweezil le 07/04/2008 @ 16:29

Bonjour,

j'utilise votre logiciel pour tester rapidement un serveur smtp, mais si il fonctionne correctement en local (envoi a partir de la machine ou est installer le serveur) il ne fonctionne pas lorsque j'envoie un mail a partir d'une autre machine du réseaux (aucun popup de confirmation) alors que le serveur smtp est bien accessible et que l'envoir de mail via telnet ou outlook fonctionne .... mais pourquoi donc :_(

cordialement

[réponse de damien, le 07/04/2008 à 19h02]

Rien dans l'appli ne peut expliquer le problème. Il faut donc chercher du côté de la config (l'adresse IP ou le nom DNS du serveur SMTP est peut-être erronée, tout simplement) ou du côté du firewall/antivirus (pc et serveur). Comme je l'ai déjà dit, certains de ces outils filtrent l'utilisation du port TCP 25 et seuls les logiciels "autorisés" peuvent l'utiliser...

Merci de m'informer des suites.


Réaction n°28 

par vince le 07/02/2008 @ 14:14

Bonjour,

A la recherche d'un 'sendmail' pour windows, votre logiciel semble bien correspondre, félicitation.

Une petite suggestion pour l'utilisateur en ligne de commande que je suis : Serait il possible que le corps du message soit passé en paramettre directement, sans passer par un fichier ?

Vincent

[réponse de damien, le 07/02/2008 à 18h49]

Oui c'est possible, j'ajouterai cette option dans la prochaine version mais elle n'est pas prête de sortir... j'ai entrepris des modifications il y a déjà fort longtemps mais rien n'est encore terminé. pas ma faute