Plugin TranslatorBox

Ce plugin met à disposition une boite latérale (que vous devrez ajouter via la rubrique "Config boites" du panneau d'administration) qui permettra aux visiteurs de votre site de le traduire dans plus de 70 langues. Il s'agit bien entendu d'une traduction automatique qui s'appuie sur le service de traduction de Google.

Plugin en FR/EN pour GuppY (compatible versions 5.x et 6.x) à installer depuis la fonction "Installer" du panneau d'administration (rubrique "Administration générale"). Grâce au système de contrôle de mise à jour d'HPSAM, ce plugin vous informe quand une mise à jour est disponible.


Télécharger Télécharger ce plugin pour GuppY 5.x et 6.x


Date de création : 24/10/2013 @ 12:56
Dernière modification : 09/01/2021 @ 14:43
Catégorie : - Plugins pour GuppY v5.x et 6.x
Page lue 25125 fois
 

Réactions à cet article

Réaction n°5 

par jean-mary le 03/03/2022 @ 17:32

la version du plugin est bien à jour.

[Réponse de damien, le 03/03/2022 à 19h57]

OK. Merci pour ta réponse.

Bon, j'ai creusé du côté de mon site et j'obtiens le même warning lorsque je réactive les rapports d'erreur pour ce fichier.

Je vais contacter la GuppY Team pour leur demander ce qui a changé concernant cette variable $hwdynabox qui n'est plus initialisée en amont de mon plugin. Je dois déjà le faire pour leur signaler une régression sur un autre sujet.

En attendant je te propose 2 contournements :

  • soit tu ajoutes la variable en fin de ligne 19 (celle qui commence par "global")
  • soit tu désactives les warnings pour le fichier /plugins/translatorbox/inc/main.inc en y ajoutant, en ligne 2 ceci : error_reporting(E_ALL & ~E_NOTICE & ~E_WARNING);

Réaction n°4 

par jean-mary le 03/03/2022 @ 10:41

Bonjour,

depuis ma dernière mise à jour vers guppy6.00.07, voici ce qui m'est affiché :

Warning: Undefined variable $hwdynabox in /var/www/legtux.org/users/esperanto-tours/www/plugins/translatorbox/inc/main.inc on line 67

Adresse de mon site :

https://esperanto-tours.legtux.org/index.php?lng=fr

Cordialement. Jean-Mary

[réponse de damien, le 03/03/2022 à 12h02]

Je ne rencontre aucun problème sur mon site. La version du plugin est-elle bien à jour ?


Réaction n°3 

par Jack_Carps le 08/02/2020 @ 18:16

This tool has been very helpful for me. It is amazing how we can now translate whole web pages so now the world can be even more connected than ever.  We are based outside Miami so get a lot of Spanish speaking people and many others because we are a tourist destination. Having this option is very helpful to us so I don't have to answer many questions over the phone.

Thank you,

Jack

PS: The troll kinda freaks me out.

[answer from damien, on 2020-02-08 at 7h45 pm]

The credit goes mainly to Google, not to me...


Réaction n°2 

par tenomis le 12/01/2020 @ 10:59

Bonjour,

je voulais simplement savoir s'il était maintenant possible de choisir les langues dans lesquelles traduire.

Cordialement. Jean-Mary

[réponse de damien, le 12/01/2020 à 20h38]

C'était déjà possible depuis la version v1.4 sortie en février 2018 et ça l'est toujours.


Réaction n°1 

par tenomis le 26/09/2017 @ 21:37

Bonjour,

j'ai installé ce plugin pour voir.

Puis je l'ai désinstallé. Quand j'ai raffiché ma page d'accueil, j'ai eu une erreur fatale. Pour éviter ceci, il faut d'abord enlever translatorbox de la boite latérale.

Je trouve qu'il serait bien de pouvoir choisir ou au moins supprimer les langues non souhaitées, notamment dans le cas d'un site existant déjà en plusieurs langues.

Translatorbox fonctionne parfaitement sur votre site, ce qui n'est pas le cas sur le mien : la présentation est complètement modifée et si je clique sur original, je ne le retrouve pas tel que je devrais. Constatez par vous même sur mon site bilingue français esperanto :

http://esperanto-tours.legtux.org/index.php?lng=fr

Cordialement.

Jean-Mary

[réponse de damien, le 27/09/2017 à 16h48]

La procédure de désinstallation est une procédure standard de GuppY. Tu rencontreras le même problème en supprimant d'autres plugins si tu n'as pas pensé à en désactiver l'affichage en barre latérale.

S'agissant de la présentation modifiée sur ton site, là encore le plugin n'en est aucunement responsable. En fait, le plugin se contente d'invoquer l'API Google Translator en lui fournissant l'url à traduire et de quelle langue source vers quelle langue cible. Tu peux faire le test en te rendant directement sur https://translate.google.fr/. Tape l'url de ton site dans la zone de gauche, sélectionne une langue dans la zone de droite, clique sur "Traduire" et enfin clique sur le lien traduit dans la zone de droite. Tu obtiendras le même résultat qu'en passant par mon plugin depuis ton site.

Enfin, pour ce qui est d'offrir la possibilité de choisir les langues à afficher, je t'avouerais que j'y pense depuis un petit moment déjà. Et ton message est un argument supplémentaire pour me convaincre. Je vais donc œuvrer dans ce sens prochainement. cligne