En poursuivant votre navigation sur ce site, vous acceptez l'utilisation de cookies pour vous proposer des contenus et services adaptés.
Mentions légales.

FreeZappette // Emulateur de télécommande pour Freebox (v5 et v6)

freezappette01.png

Ce petit outil permet de piloter le boitier HD de la Freebox en se substituant à la télécommande. Bref, c'est un vrai gadget !

La première version, développée en moins de 3 heures juste pour le fun, était assez rudimentaire. A la demande des premiers utilisateurs, j'y ai ajouté la liste des chaines et un clavier virtuel. Plus récemment, la compatibilité (non testée par moi puisque n'étant plus chez Free) avec la Freebox V6 a été ajoutée...

N'hésitez pas à poster vos retours, positifs ou faisant état de dysfonctionnements. Je ferai mon possible pour corriger les éventuels problèmes, bien que je ne puisse tester l'appli puisque ne possédant plus de Freebox.

Télécharger Télécharger ce logiciel (version installeur)
Télécharger Télécharger ce logiciel (version portable ZIP) Note importante aux utilisateurs des versions portables


Date de création : 30/04/2010 @ 23:42
Dernière modification : 22/08/2020 @ 16:26
Catégorie : - Outils obsolètes
Page lue 55573 fois
 

Réactions à cet article

Réaction n°30 

par gice le 13/05/2010 @ 21:56

J'ai fais 2 choses aujourd'hui, j'ai redemarré mon PC (ce que je ne pense pas avoir fait depuis le premiere installation)et j'ai relancé Freezappette apres avoir basculé en free tv classique.Je viens de supprimer le .ini et le channels.txt et rebasculer en mode bas débit et ca marche qd meme.Donc le redemarrage a du être le bon remede.

[réponse de damien, le 14/05/2010 à 07h02]

C'est clair que ça résout souvent pas mal de problèmes de rebooter la machine de temps en temps ! cligne

Reste à savoir si ça va résoudre le problème chez les 2 ou 3 autres utilisateurs qui l'ont rencontré. Je ne pense pas mais bon, c'est une piste ! En tout cas, merci de ton retour.


Réaction n°29 

par gice le 13/05/2010 @ 20:29

Finalement, c'est bon meme en passant par le mode faible débit (depuis le menu free).Il a fallu passer en mode classique a la premiere utilisation de freezappette pour l'initialisation et puis apres c'est bon ca marche niquel.

bye

[réponse de damien, le 13/05/2010 à 21h02]

Non, je pense sincèrement que le problème est ailleurs. Pour confirmer, peux-tu supprimer le fichier channels.txt puis relancer FreeZappette et voir si le problème se reproduit (en mode bas débit, et refais la même manip en mode classique)...

Merci pour tes tests.


Réaction n°28 

par gice le 13/05/2010 @ 20:18

Je viens de comprendre la cause de l'erreur N°9.Le probleme vient du fait que j'utilise la freebox Hd en mode bas débit et non classique.En forcant le mode classique, c'est ok.Par contre ce mode ne m'interesse pas compte tenu de mon débit.Si t'avais une solution....

A+

[réponse de damien, le 13/05/2010 à 20h59]

Alors là je suis surpris car j'utilise moi-même le mode bas débit et ça fonctionne sans rencontrer cette erreur... Il faut chercher l'explication ailleurs. déconcerté


Réaction n°27 

par   PH1L1PP3 le 13/05/2010 @ 18:38

petite précision

je n'ai pas de répertoire C:\Users\#NOM_DU_PROFILE#\AppData\Local\VirtualStore\Program Files\Dipisoft\FreeZappette\FreeZappette.ini

[réponse de damien, le 13/05/2010 à 20h53]

Le répertoire "Users" doit s'appeler "Utilisateurs" si ton OS est en français. D'autre part (je ne l'avais pas précisé car ça me semblait évident), le "#NOM_DU_PROFILE#" est à remplacer par le nom du profile, donc "toto" si ton compte est "toto". Enfin, le répertoire "AppData" est un répertoire masqué, il faut donc modifier les options d'affichage des dossiers pour le voir.


Réaction n°26 

par   PH1L1PP3 le 13/05/2010 @ 18:33

bonsoir,
 moi aussi j'ai le même problème que précédemment
- OS:Windows Vista 64
- version 0.4 installeur
- chaînes payantes (C+)
- fonctionne sous XP SP3
- *.ocx enregistré sans problème

[réponse de damien, le 13/05/2010 à 20h47]

Pour l'instant je n'ai eu l'occasion de tester l'appli uniquement sur des XP/WIN7 32 bits. Je vais essayer de tester en 64 bits demain sur une VM du boulot.

Et si ça ne suffit pas pour trouver une piste, je tenterais une prise de main sur la machine d'un autre utilisateur qui était d'accord. Si tout va bien, j'espère que ça va rentrer dans l'ordre rapidement.

Désolé pour le désagrément.


Réaction n°25 

par   gice le 11/05/2010 @ 20:30

Merci pour ta reponse.J'ai rajoutté le fichier .ini a la main dans le repertoire que tu as indiqué.Mais apres program files, le sous repertoire Dipisoft n'existait pas. Je l'ai créé aussi pour y mettre le .ini.
Après, en executant l'application, il me demande toujours le numero de la telecommande alors qu'en toute logique, le fichier devrait lui suffire. Bizarre !
Pour repondre à ta question, j'ai pas d'abonnement a des chaines particulieres.
Le probleme survient apres avoir cliquer sur ok au bout de 1 ou 2 secondes. Regarde peut etre dans ton code entre la procedure declenchée par le OK et la creation du freezappette.ini car celui-ci n'a pas le temps d'être créé.
Autre chose, j'ai aussi essayer d'executer le logiciel en mode de compatibilité WinXP et Vista.Confirme moi l'emplacement où mettre le freezappette.ini.

A+

[réponse de damien, le 11/05/2010 à 23h24]

En fait, il n'est pas surprenant que le répertoire DipisoftFreeZappette n'existe pas encore dans le Program Files du VirtualStore puisque le fichier .ini n'est généré qu'au moment de quitter l'outil. Dans la mesure où l'appli plante au démarrage, le fichier n'est pas écrit sur le disque.

Maintenant, si tu l'as créé manuellement au bon endroit (n'aurais-tu pas mis le .ini directement dans Dipisoft en oubliant le dossier FreeZappette ?), l'appli devrait le trouver et ne plus te demander le code de la télécommande. Donc à ce niveau il y a quelque chose de bizarre. Une chose à savoir sous Windows 7 : le placement des fichiers .ini dans le VirtualStore ne concerne pas le compte Administrateur : dans ce cas précis, les fichiers .ini sont placés dans le répertoire habituel (celui de l'exécutable dans le cas de mes outils). Je ne sais pas ce qu'il en est si l'UAC est désactivée... peut-être alors que le VirtualStore l'est aussi pour tous les comptes ? A voir...

Enfin bref, pour essayer d'y voir un peu plus clair, je te propose 2 choses :

  • peux-tu récupérer le fichier "channels" et me l'envoyer, c'est peut-être lui qui présente une anomalie. Pour le récupérer, utilise ton navigateur et saisis l'url suivante : http://hd1.freebox.fr/pub/channels (ou hd2 le cas échéant).
  • si tu es d'accord, je te propose d'organiser une prise de main à distance sur ta machine à l'aide de TeamViewer par exemple... C'est toi qui voit.

Quoi qu'il en soit, merci d'avance et désolé pour la gène occasionnée...


Réaction n°24 

par   gice le 11/05/2010 @ 13:05

Bonjour J'ai le meme probleme que Pat94220 à savoirErreur d'execution '9' : 
Indice en dehors de la  plage 

Je tourne sous Windows 7 et essaye d'utiliser la dernière version de ton site.
Apres recherche sur le disque, aucune trace de fichier freezappette.ini.
J'en ai créé un, a la main avec tes indications et l'ai enregistré dans le repertoire de l'executable. Et ca n'a rien changé.
Sinon, Où faudrait-il le mettre ?
Merci pour ton aide, car je suis impatient de tester ton logiciel.
A+

[réponse de damien, le 11/05/2010 à 18h48]

Ah, un second à rencontrer la même erreur ? Intéressant...

Sauf que dans ton cas, l'OS est différent. Et sous Windows 7 (comme sous Vista), les fichiers .ini ne se trouvent pas dans le répertoire de l'appli mais dans le "virtualstore"... Il te faut donc regarder dans le dossier :

C:\Users\#NOM_DU_PROFILE#\AppData\Local\VirtualStore\Program Files\Dipisoft\FreeZappette\FreeZappette.ini

Je ne vois pas bien quel traitement pourrait produire cette erreur, en dehors peut-être de la récupération de la liste des chaînes... es-tu abonné à des chaînes supplémentaires (CanalSat par exemple ?) ou seulement les chaînes gratuites ?

Tiens moi au courant stp...


Réaction n°23 

par   Pat94220 le 10/05/2010 @ 18:49

Merci de répondre si vite, t'as pas a t'excusé deja c'est gratuit alors je vais pas me plaindre pour si peux !!

La version c'est "installeur" que j'ai téléchargé sur ton site aujourd'hui meme.
ça se produit apres la saisie du code de la zappette et j'ai windows XP 5.1 SP  3

Merci.

[réponse de damien, le 10/05/2010 à 20h52]

Bon, eh bien j'ai eu beau essayer de reproduire le "bug" de mon côté et nada : installation de la dernière version sur une VM toute propre sous XP SP3 à jour de tous les correctifs, je ne rencontre pas le problème.

Est-ce que le plantage se produit à chaque fois ?

Est-ce que le fichier FreeZappette.ini a été créé ? Si oui, essaye de le supprimer. Si non, crée-le avec les "bonnes" informations tel que suit :

FreeZappette.ini
[Config]
CodeTélécommande=xxxxxxxx
(où xxxxxxxx représente le code télécommande à récupérer dans l'interface de la Freebox HD)
Hd=x (où x représente le numéro du boitier HD, donc 1 en principe mais ça peut être 2 si tu as 2 boitiers)

Tiens-moi au courant stp.


Réaction n°22 

par   Pat94220 le 10/05/2010 @ 16:41

juste un petit problème quand je tape le code de la télécommande j'ai le message d'erreur suivant :
Erreur d'execution '9' :
Indice en dehors de la  plage

Domage l'idée était séduisante.

[réponse de damien, le 10/05/2010 à 17h56]

Tu es le premier à me signaler ce problème.

Peux-tu m'en dire plus sur le contexte exact dans lequel ça se produit ? Notamment :

  • version de Windows,
  • version de FreeZappette (n° + installeur ou portable),
  • est-ce que ça se produit au moment de la saisie, au moment de la validation, quelques instants après la validation ?

Merci d'avance de ta réponse et désolé de la gène occasionnée...


Réaction n°21 

par   jpcgt34 le 10/05/2010 @ 09:59

C'est excellent!!!
Juste une petite suggestion : pouvoir zoomer l'image de la télécommande.
Avec une définition de 1920 par 1200 pixels l'image de la zapette est trop petite.

[réponse de damien, le 10/05/2010 à 17h50]

Je vais étudier ça mais je ne te promets rien... pas ma faute