Ce site dans votre langue

French English Arabic Bulgarian Catalan Chinese (simplified) Chinese (traditional) 
Croatian Czech Danish Dutch Filipino Finnish German 
Greek Hebrew Hindi Indonesian Italian Japanese Korean 
Latvian Lithuanian Norwegian Polish Portuguese Romanian Russian 
Serbian Slovak Slovenian Spanish Swedish Ukrainian Vietnamese 

Plugin TranslatorBox par Dipisoft
Merci à Google Traduction

Traductions des logiciels

Les logiciels proposés sur ce site
sont nativement en français...

... certains (identifiés par le picto multilingue.png),
sont fournis avec des fichiers
de langues supplémentaires.

Apportez votre pierre à l'édifice en
améliorant des traductions existantes...

... ou en ajoutant des nouvelles
traductions à certains logiciels.

Pour ce faire, rendez-vous sur la page
des fichiers de langues et
rejoignez la liste des contributeurs !

Dons / Contributions

A titre d'information, l'hébergement et le nom de domaine de ce site me coûtent 87€/an, montant non atteint en dons ces 2 dernières années.

Alors si vous souhaitez participer...

... vous rejoindrez ainsi la liste des

Visites

 1666687 visites

 7 visiteurs en ligne

Newsletter
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
c6TeDX
Recopier le code :
475 Abonnés
Recherche sur ce site
Recherche sur ce site
Réseaux sociaux
wakeonlan01.png
francais english deutsch espanol italiano portugues romana
WakeOnLan est à présent multilingue mais ne possède actuellement que très peu de traductions :
  • Français (OK, référence)
  • Anglais (à contrôler)
  • Allemand (à contrôler)
  • Espagnol (à contrôler)
  • Italien (à contrôler)
  • Portugais (à contrôler)
  • Roumain (à contrôler)
Si vous souhaitez compléter les fichiers existants ou ajouter de nouvelles traductions, rendez-vous sur la page des fichiers de langues.


Besoin d'intervenir sur un pc situé dans un bureau éloigné du votre et sur lequel vous possédez des droits d'administration (ou de connexion au bureau à distance) ? Le hic, c'est que cela n'est possible que lorsque la machine en question est allumée...

Plutôt que d'utiliser certains outils du même genre mais à l'ergonomie discutable, essayez ce WakeOnLan avec lequel vous allez pouvoir tester l'état des machines (grâce à des Ping très rapides) que vous aurez préalablement déclarées et redémarrer celles que vous souhaitez en un seul clic.

A noter que le réveil d'un pc n'est possible que :

  • s'il possède un adaptateur réseau (intégré à la carte-mère ou carte additionnelle) compatible avec le réveil à distance,
  • si cet adaptateur est raccordé au connecteur WOL de la carte-mère (sur les anciennes configurations matérielles)
  • si cet adaptateur est correctement configuré (paramétrage sous Windows)
  • si le BIOS de la machine est configuré pour permettre le réveil à distance

Mais le réveil à distance n'est pas la seule corde que cet outil a à son arc puisqu'il permet aussi de redémarrer, d'éteindre, de mettre en veille prolongée, de fermer/verrouiller la session sur une ou plusieurs machines distantes. Il faut toutefois que la configuration de la machine 'cible' le permette : le service 'serveur' doit notamment être démarré et vous (l'utilisateur qui souhaite éteindre la machine à distance) devez avoir des privilèges suffisants. A noter que certaines fonctionnalités ne sont pas accessibles aux postes sous Win9x...

Depuis la v3.0, WakeOnLan peut aussi être utilisé en mode ligne de commande. Pour plus d'informations à ce sujet, ouvrez une fenêtre d'invite de commandes, placez-vous dans le dossier dans lequel se trouve l'appli, et tapez WakeOnLanBatch /? (ça fonctionne aussi sans paramètre).

Avec la sortie de la v3.2, l'outil offre désormais la possibilité de réveiller des machines via Internet (fonctionnalité WakeOnWan, ou WOW)...
 

  Télécharger ce logiciel (version installeur)   Télécharger le script wakeonwan.php
  Télécharger ce logiciel (version portable ZIP) Note importante aux utilisateurs des versions portables


Date de création : 18/03/2005 @ 23:39
Dernière modification : 21/12/2016 @ 13:16
Catégorie : - Aide à l'administration
Page lue 108836 fois


Réactions à cet article

Réaction n°144 

par JM33 le 03/03/2010 @ 23:32
J'ai essayé de faire le test directement sur ma machine... c'est pareil. En fait dès que je mets l'adresse publique dans la case IP, ça marche pas. J'ai une freebox V5 ça viens peut être du paramétrage (j'ai bien configuré en cochant la case pour faire du WOW..) Je comprends pas..


[réponse de damien, le 03/03/2010 à 23h56]
Ouais, y a vraiment un truc qui merde quelque part ! Si tu veux (mais pas ce soir hein !), on peut tenter une prise de main via TeamViewer pour essayer de diagnostiquer...

Réaction n°143 

par JM33 le 03/03/2010 @ 23:18
En fait j'ai déjà fait les tests hier et je viens de les refaire, avec WOL rien ne se passe sur WOL monitor du pc à réveiller. Dès que je le fais par le service en ligne, les paquets arrivent...


[réponse de damien, le 03/03/2010 à 23h52]
Ce n'est vraiment pas normal... mais pour lever un doute : quand tu dis "avec WOL rien ne se passe sur WOL monitor", tu parles du réveil en général avec mon outil ou seulement du réveil via Internet ?

D'après tes explications, j'ai l'impression que c'est un problème avec le l'ActiveX "Inet.ocx" utilisé pour accéder à Internet. Mais au fait, tu utilises quelle version de WakeOnLan : la version installée ou la portable ?

Réaction n°142 

par JM33 le 03/03/2010 @ 23:12
Merci beaucoup pour ta réponse.
En fait j'ai bien pris soin de faire bien attention aux saisies.
De plus ce phénommène se produit sur tous les ordi que j'ai testés avec différents parefeux. J'ai aussi testé avec Depicus c'est pareil!!!! je ne comprends vraiment pas car ça marche super bien depuis le service en ligne....
Bon en même temps j'ai une solution qui fonctionne mais je trouvais l'utilisation de WOL très pratique. Je cherche encore...
A bientôt et merci pour ce site vraiment bien fait.
JM


[réponse de damien, le 03/03/2010 à 23h44]
Tu n'as pas répondu à ma question : quand tu dis que ça fonctionne depuis le service en ligne, tu parles de celui de mon site ou d'un autre ?

Réaction n°141 

par JM33 le 03/03/2010 @ 11:04
Je précise mon précédent message. J'ai vu les solutions déjà proposées un peu avant. Rien n'y fait, pourtant j'ai mis les mêmes adresses que pour le services WOW en ligne et j'ai fait un cliq droit puis option réveiller via internet. Ca marche pas... j'ai oublié qqe chose?....
Merci
JM


[réponse de damien, le 03/03/2010 à 23h08]
Ben si tu as réellement suivi tous les conseils, à priori tu n'as rien oublié.

Maintenant, il s'agit de déterminer si le problème se situe côté boulot ou côté maison : je te conseille d'essayer de faire du WOW sur ta propre machine (perso), depuis Internet et depuis mon outil, en utilisant
WakeOnLan Monitor (de Depicus) pour voir si les paquets arrivent ou non.

Réaction n°140 

par JM33 le 03/03/2010 @ 10:55
Bonjour Damien,

Tout d'abord merci pour ces excellents programmes.
Je me permets d'intervenir juste pour un pb personnel car depuis WakeOnWan en ligne j'arrive parfaitement à réveiller un pc (sous vista) de mon bureau qui est éteint.
Par contre avec le programme WakeOnLan v3.3 je n'y arrive pas. C'est normal ? (peut-être qu'il est réservé au réveil en réseau local...). Merci de ta réponse.
A bientôt
JM



[réponse de damien, le 03/03/2010 à 22h50]
Ben non ce n'est pas normal : si ça fonctionne depuis Internet (à partir de mon site ou d'un autre au fait ?), ça devrait aussi fonctionner avec la méthode WOW de mon soft. Si ce n'est pas le cas, c'est peut-être que ton firewall ne laisse pas accéder WakeOnLan à mon site pour y exécuter le script de réveil via Internet... A moins que tu aies fait une boulette en saisissant l'IP publique ou l'adresse MAC de la bécane.

Réaction n°139 

par djipi le 03/03/2010 @ 09:10
merci!
 Pas de soucis je suis la dessus depuis pas mal de temps et tu n'as aucune obligation je trouve le délais plus que bien il est des fois bien plus long sur des assistance de logiciels avec abonnement de maintenance payante!!
quand la chaudière ne marche pas il faut effectivement une bonne isolation n

j'ai fait tout cela mais je n'ai effectivement pas la fonction proxy WOL cependant j'ai réussi hier soir à le démarrer parametrant dans le routeur l'adresse privée du pc en DMZ.
Le soucis c'est que depuis hier soir il redémarre sans arrêt du coup d
il doit prendre tout les paquets magiques qui trainent je suppose...
je continue mes tests...


[réponse de damien, le 03/03/2010 à 22h33]
Bizarre que ta bécane se réveille sans cesse en la plaçant en DMZ. A ta place, j'essayerais de voir de quelle(s) adresse(s) IP viennent les paquets à l'aide d'un outil tel que
WakeOnLan Monitor (de Depicus).

Réaction n°138 

par djipi le 01/03/2010 @ 17:40
salut,
j'ai un xp avec une carte A7n8x deluxe le cable réseau sur la carte Marvell et en WOL ça marche nickel en réglant le bios et la carte reseau. Simple , efficace et plus joli que d'autres!
ça m'evite de descendre 1 etage k
Bravo!
Par contre je n'arrive pas à le reveiller en WOW ce qui était mon but au départ. Je mets le nom netbios, l'adresse DNS, j'utilise le port 9 et je fais un clique droit reveil par internet mais il ne se passe rien.
Chez moi j'ai un routeur LINKSYS j'ai ouvert le port 9 pour l'adresse ip fixe privée du pc a reveiller.
 En faisant pas mal de recherches j'ai trouvé des infos sur mon routeur qui n'accepte pas les broadcast et qui ne garde pas en mémoire la table ARP qui associe l'adresse IP et L'adresse MAC.
Quand le pc est eteint il disparait de cette table. Ce qui doit faire que le routeur ne doit plus savoir à quel pc s'adresser y
Si j'ai bien tout compris car ce n'est pas du tout mon domaine...
Voyez vous un moyen de contourner cela? ou c'est mortd


[réponse de damien, le 03/03/2010 à 01h22]
Désolé pour le retard de ma réponse : je suis en vacances et Mme ne m'a pas laissé d'autre choix que de bosser dans la maison (isolation)... et pour couronner le tout cette soirée a sonné le retour des emmerdes avec ma chaudière. VDM...

Bon, ça c'est ma vie, et j'imagine que tu t'en "bats les couettes" (en tout cas ce serait mon cas si ça ne me concernait pas ! biggrin ) alors j'en viens à ton problème de WakeOnWan : quand tu dis que tu met le nom NetBIOS et l'adresse DNS, je t'avouerais que je ne comprends pas bien... Je vais donc faire un petit récap qui pourra aussi servir à d'autres quand on veut faire du WOW :
 - dans le champ "Adresse IP (ou nom NetBIOS/DNS)", indiquer l'adresse IP publique fournie par ton FAI ou le nom DNS correspondant, notamment si tu as une connexion sans IP fixe et que tu utilises un service du style Dyndns.
 - dans le champ "Adresse MAC", indiquer l'adresse MAC du poste que tu veux réveiller
 - dans le champ "Port" (facultatif), indiquer le port à utiliser pour le réveil. S'il n'est pas renseigné c'est le port par défaut qui sera utilisé (voir fenêtre de configuration générale de l'outil). Sa valeur dépend essentiellement de la configuration de ta box, et notamment du port que tu auras ou non routé vers ton PC à réveiller.

Maintenant, si ton routeur ne conserve effectivement pas la table de routage et qu'il n'intègre pas de fonction "proxy WOL" (comme sur la FreeBox par exemple), je ne vois pas trop de solution... et puis je ne saurais te donner de plus amples conseils concernant la config de ton routeur que je ne connais pas, mis à part de te plonger dans sa doc ou de contacter le support.

Désolé de ne pouvoir t'être d'une plus grande utilité. frown

Réaction n°137 

par Chris le 24/02/2010 @ 15:49

Bonjour,

Tout d'abord merci pour votre boulot, votre réactivité et votre disponibilité.

Dans un cadre professionnel, je cherche à utiliser WOL en mode batch pour des "lots" de stations au travers d'une commande AT afin de les réveiller. Mais ça ne fonctionne pas. Je pense que ma ligne de commande n'est pas bonne. Que dois je mettre exactement ?

Encore merci

 

[réponse de damien, le 24/02/2010 à 18h59]
Tu dis que ça ne fonctionne pas et que tu penses que ta ligne de commande est bonne, c'est bien mais ne crois-tu pas que nous aurions gagné du temps si tu avais fait un copier/coller de cette fameuse ligne de commande ?! wink

Il y a quelques exemples à la fin de l'aide qui s'affiche quand WakeOnLanBatch.exe est exécuté sans paramètre, j'imagine que tu t'en es inspiré ? Peu importe, je te joins ci-dessous 2 exemples qui, d'après les infos que tu donnes, sont susceptibles de t'aider...

Le plus simple, si tu veux réveiller toutes les machines définies dans le fichier de config de WakeOnLan :

wakeonlanbatch.exe /w:*
Si tu as organisé ta structure dans plusieurs dossiers et que tu veux réveiller toutes les machines d'un même dossier :
wakeonlanbatch.exe /w:dossier1!*
J'espère que ceci t'aidera, sinon n'hésite pas à me recontacter en me donnant un peu plus de précisions.

Réaction n°136 

par Pascal le 18/02/2010 @ 09:35
BonjourJe suis en train d'essayer de faire du WOW mais pas sans peine...je m'explique:J'essaie de réveiller, redémarrer ou mettre en veille mon pc à la maison depuis le boulot ou depuis chez des amis.Je pense avoir fait le nécessaire sur le bios, la carte réseau,....Lorsque j'installe le sniffer de Depicus sur mon Pc pour voir si je reçois les paquets magiques, je les reçois lorsque je les envoies depuis le service en ligne WOW mais pas lorsque j'utilise le soft Wake on Lan.Pouvez-vous me dire ce que je fais de faux déjà à cette étape là?
Merci

 
[réponse de damien, le 18/02/2010 à 16h16]
Si ça fonctionne avec la page de réveil de mon site (ou n'importe quelle autre d'ailleurs), c'est déjà bon signe !

Il est probable que tu aies donc mal configuré l'appli ou que tu ne l'utilises pas correctement : une erreur régulièrement commise, c'est l'utilisation du bouton "réveiller la sélection" quand on veut faire du WOW. En effet, ce bouton ne concerne que le WOL ! J'avoue que ce n'est pas très explicite et j'ai d'ores et déjà corrigé le problème dans la nouvelle version qui sortira sous peu. En attendant, il faut faire un clic droit sur la machine à réveiller (ou du moins sur une de celles qui sont sélectionnées s'il y en a plusieurs) et sélectionner l'option "Réveiller via Internet (WOW) dans le menu contextuel qui apparaît...

Une autre erreur : c'est d'utiliser une adresse IP privée (genre 192.168.0.x) pour le WOW alors qu'il faut obligatoirement utiliser l'IP publique de la machine, bien évidemment.

Enfin, il est aussi possible que tu aies répondu "Bloquer" à la fenêtre que le firewall propose quand il s'aperçoit que mon soft tente d'accéder à un site web (le mien ou un autre si tu as spécifié un script WOW tiers). Dans ce cas il te faudra revoir la configuration du firewall pour autoriser mon appli.

Voilà, tiens moi au courant si mes conseils t'auront été utiles ou si au contraire le problème persiste...

Réaction n°135 

par rike le 05/02/2010 @ 11:48
Salut,
je n'ai malheureusement rien trouvé de très probant, que ce soit dans le BIOS ou les réglages de la carte réseau...ce sont des ACER veriton qui datent de 2008. Il y a bien un paramètre "wake from shutdown" qui agit aléatoirement : certaines s'allumaient juste après l'extinction, d'autres non, et justement avec ces dernières j'ai pu les allumer via WOL. 

J'ai d'autres ACER de la série power qui font la même chose...et pourtant les LEDs réseau sont bien allumés, tout est bien configuré. N'ayant pas les docs, et n'étant même pas sur le site d'ACER (génial !) je crois que je vais laisser tomber. 

Les cartes réseaux sont de la marque MARVELL Yukon, j'ai tenté avec les dernières MAJ de drivers mais rien n'y fait. J'ai un de ces ACER qui a une carte externe Realtek extrèmement basique (3 paramètres peuvent être changés) et le WOL fonctionne nickel d alors que ces MARVELL bardés de paramètres ne veulent rien savoir.

Je suis peut être passé à coté de quelquechose....



[réponse de damien, le 05/02/2010 à 18h56]
Désolé, je n'ai rien de plus à te proposer que les conseils précédents... frown

Réaction n°134 

par rike le 03/02/2010 @ 15:51
Bien le bonjour mon ami !!!

Me voilà de retour !!! J'ai une salle de 21 pc (Vista pro) mais le hic c'est que, quand ils sont éteints, ils le sont complètement, c'est-à-dire que la carte réseau n'est plus alimentée (led non allumée).

Est-ce que cela vient de ces fameux états S1, S2...??? Sais-tu quels paramètres faut-il changer dans le BIOS ?

Je vais de ce pas continuer mes investigations !
@+

 
[réponse de damien, le 03/02/2010 à 20h07]
Pour commencer, as-tu activé l'option permettant le réveil (wake-up by pci ou un truc dans le genre) ? Ensuite, il faut aussi regarder du côté des propriétés de la carte réseau mais ça, c'est sous Windows que ça se fait, pas dans le Bios. Enfin, certains Bios permettent effectivement de définir l'état de la machine quand elle est arrêtée ou qu'elle passe en veille...

Je te conseille de regarder du côté de la doc de la carte-mère.

Réaction n°135 

par michel le 27/01/2010 @ 09:42

Bonjour et un grand merci car je révais depuis longtemps de pouvoir révéiller des machines à distance et vous me l'avez permis. Dommage que je n'ai eu connaissance de vos softs avant  (car maintenant retraité- je m'occupait il y à peu du parc informatique de mon lycée-). Je me permet de vous poser une question.

J'ai l'habitude de débrancher la prise de courant quand j'éteint mes machines

j'ai testé le WOL et le WON (ce dernier avec vos 2 softs) et j'ai constaté avec bonheur que le réveil était possible si la machine cible avait été préalablement allumée directement puis éteinte sans avoir débranché la prise de courant. Si la prise a été débranchée puis rebranchée le réveil n'est pas possible. Est-ce normale

 

[réponse de damien, le 27/01/2010 à 16h37]
Ce n'est pas le cas de toutes les machines mais effectivement, certaines ne "veulent" pas se réveiller après avoir été privées d'alimentation électrique. Lorsque l'on rebranche la prise de courant, la carte-mère semble ne pas alimenter la carte réseau (les leds restent éteintes) et le WOL/WOW est donc impossible... Je n'y puis rien, désolé.

PS.: je déplace ton message vers les réactions à l'article sur WakeOnLan, sa place dans le livre d'or n'étant pas des plus adaptées. wink


Réaction n°132 

par rike le 25/01/2010 @ 09:37
Hum hum !!!!!!!!!!
En fait, euh comment dire ??? 
La machine était déconnectée du domaine d (OK je sors !)
En tout cas, merci pour tes réponses et ta réactivité !

A bientôt (c'était un test pour une salle seulement, qui est validé maintenant)
Donc je reviendrai sûrement par ici^^
@+

 
[réponse de damien, le 25/01/2010 à 11h00]
C'est comment qu'on dit dans un cas comme ça normalement ? Ah oui : "No comment!" biggrin

PS.: c'est mon anniv' vendredi ('tain 40 piges), je sais qui va me payer le champ' ! Youpi ! tongue

Réaction n°131 

par rike le 25/01/2010 @ 09:20
Bonjour,

j'ai avancé ! 
Une machine reste donc récalcitrante...Elle ne se réveille pas, ne s'éteint pas, ne redémarre pas (WMI or not).
Pourtant les paramètres du BIOS et de la carte réseau sont corrects.

Est-ce un cas désespéré ? C'est une machine que j'ai réinstallé proprement récemment,je ne vois pas d'où pourrait venir le problème (services, stratégies)


[réponse de damien, le 25/01/2010 à 10h56]
Euh... elle est bien connectée au réseau quand même ?! Tu sais, c'est à ça que sert le câble RJ45 ! eek

Réaction n°130 

par NeoPhil le 23/01/2010 @ 21:08

Bon j'ai réussi sans bien du mal ^^

J'ai rajouté en dur l'adresse mac de mon pc a reveiller dans ma LB ; par contre je ne peux pas utiliser ton script car il ne fonctionne pas pour moi et quand je l'upload sur mon ftp j'ai l'erreur suivante = Call to undefined function: filter_var() in /****/www/wakeonwan.php on line 59 ^^

Par contre j'ai reussi chez depicus :) ici http://www.depicus.com/wake-on-lan/woli.aspx ca marche car j'ai changé mon masque de sous reseau en 255.255.255.25 et ca fonctionne et du coup j'ai reflechi et pour que cela fonctionne avec ton soft j'ai rajouté un autre pc (qui est le même physiquement mais cette fois avec la vraie ip, testé aussi avec ma dns dynamique, et j'ai modifié l'adresse de masque de sous reseau comme cité au dessus et du coup ca fonctionne à merveille de chez moi en local et chez mon voisin :)

Et voilà me reste plus qu'à comprendre l'erreur dans le script php :)

 

[réponse de damien, le 23/01/2010 à 21h31]
Qu'est-ce qui ne fonctionne pas : le WOW depuis mon appli ou depuis le formulaire de mon site ? Dans les 2 cas, n'oublie pas qu'il faut spécifier l'IP PUBLIQUE de ta connexion et non l'IP PRIVEE de la machine cible... tongue

Je ne vois pas pourquoi le WOW du site de Depicus ne donnerait pas le même résultat que le mien. Quant au masque, il n'est pas utilisé pour le WOW depuis mon appli, comme c'est indiqué dans la fenêtre de configuration. C'est le script PHP qui envoie le paquet directement sur l'IP spécifiée (donc en utilisant implicitement un masque 255.255.255.255 aussi).

Enfin, pour ce qui est de l'erreur, elle se situe visiblement au moment du contrôle que l'IP est correcte (IPv4 bien formée). Peut-être qu'OVH interdit l'utilisation de cette fonction... frown


Réaction n°129 

par NeoPhil le 23/01/2010 @ 19:25

Nan j'avais pas encore testé le wow, je suis dessus en ce moment, pour ce qui est de l'hébergement j'ai tout ce qui faut sur mes serveurs "OVH", pour le taf pas de soucis j'ai du dmz ^^ le hic chez moi c'est ma saleté le Livebox, y a un gros problème avec le won ^^

Je suis entrain de tenter de modifier arp pour créer regles de routage permanent entre un mac adresse et ip du pc a réveiller ... pour l'instant sans résultat positif :(

je continue :)


 

[réponse de damien, le 23/01/2010 à 19h30]
Et ce n'est pas moi qui pourrai t'aider côté Livebox... frown


Réaction n°128 

par NeoPhil le 23/01/2010 @ 18:18

Pour le portable quel con je suis, j'aurais pu qd même percuté ^^ evidemment que c'est impossible pour les raisons que tu as indiqué, arff fatigué je dois être :)

Bon pour le feedback c'est normal de contribuer c'est ca l'esprit web pour moi donc il est normal de faire des retours :)

Pour info hormis les 2 unités via wifi qui doivent restées alumées sans cesse d'ou l'interêt limité, c'était un peu plus pour tester qu'autre chose d'ailleurs^^ , le reste communique sans problème, j'ai plus qu'à tester la version wow ^^ à mon taf :)

Merci pour les infos en tout cas e

 

[réponse de damien, le 23/01/2010 à 19h09]
En principe, si tu as testé le WOW depuis le formulaire de mon site et que ça fonctionne, il n'y a pas de raison que le WOW via mon soft ne fonctionne pas (dans la mesure où il envoie par requête HTTP une demande d'émission du paquet magique). Donc à moins que les admins de ton taf n'aient mis en place un filtrage interdisant l'accès à mon site, ça ne peut pas ne pas marcher. Au pire, tu pourras toujours récupérer mon script WOW qui est en téléchargement pour l'héberger ailleurs... biggrin


Réaction n°127 

par NeoPhil le 23/01/2010 @ 14:41

Merci de tes eclaircissements qui du coup ont en partie résolus mes problèmes :

Je n'ai pas les mêmes log et pass suivant les machines donc j'ai modifié pour avoir une cohérence et là les fonctions marchent à merveille et par conséquent j'utilise dans l'authentifiaction la méthode "utilisation compte spécifié", en toute honnêté j'avais zappé les options de configuration ^^ donc j'ai zappé ce menu et évidemment la personnalisation des commandes :) mea culpa ^^

Je vais finir mes tests car j'ai 2 pcs en xp + 1 pc sous 7 et 1 netbook en 7 et un portable sous 7 mais lui passe par la box (wifi) + faut que j'étudie ton script php pour le wow et avec ma livebox ca risque de se compliquer ou alors il va falloir user de la translation :)


 

[réponse de damien, le 23/01/2010 à 16h22]
Content que ça fonctionne.

Par contre, si tu veux réveiller ton portable connecté à la box en wifi, je pense que c'est mort. Je crois que ce n'est pas possible car la carte wifi ne reste pas alimentée en principe. En tout cas, moi je n'y suis pas parvenu. Regarde dans les paramètres de la carte (voir ma réponse à la réaction n°123), mais je pense que tu n'y trouveras aucun réglage de réveil à distance dans les attributs présents... frown

Au passage, merci de ton retour. Il y a tellement de personnes qui ne reviennent pas pour dire si le problème est résolu ou non. rolleyes


Réaction n°126 

par NeoPhil le 23/01/2010 @ 08:23

Excellent petit soft, rien à redire même si j'ai un petit soucis :)

Dans mon reseau tous derrières une box sont switchés simplement, mais dedans j'ai du xp Pro et du 7 et là le bas blaisse. Entre les 2 xps tout fonctionne nickel parcontre tous ce qui vient des 7 pc ou portable, là ca ne passe pas :(

"... la machine distante a rejeté la demande"

Comme j'ai lu + bas que tu allais te renseigner pour les problèmes sous 7, as-tu eu nes nouvelles à ce propose ?

ps : ce que je pige pas c'est que si je passe par ton appli quand je veux redemarrer mon pc xp ca me renvoies le message ci-dessus parcontre si je passe en ligne de commande shutdown -r -f -m xppc  la cela fonctionne ??? si cela peut t'aider l

 

[réponse de damien, le 23/01/2010 à 10h23]
Hé non, je n'ai toujours pas eu les infos attendues concernant les problèmes d'accès à WMI sous Windows 7 (en workgroup). Et je n'ai pas l'e-mail du formateur qui devait me fournir les infos, mais je ne désespère pas car la semaine qui vient, des collègues à moi vont suivre la même formation et ont entre autre la mission de lui rappeler ses "engagements" ! wink

Dans ton PS, tu dis que le reboot via la commande shutdown est fonctionnel. C'est intéressant. Du coup, je remis le nez dans cette partie du code et je vois que j'ai 2 traitements différents selon la configuration dans l'onglet "authentification" (utilisation du compte d'ouverture de session ou celui spécifié par l'utilisateur) de l'outil. Qu'as-tu utilisé comme paramétrage sur ce point ? Utilises-tu les mêmes login/password sur tes différentes machines ?

Cela dit, tu sais que tu peux ajouter des "commandes personnalisées" ? Rien ne t'empêche d'ajouter le "shutdown -r -f -m %ip%" puisque cette méthode fonctionne. wink

Merci d'avance de tes réponses.


Réaction n°125 

par rike le 22/01/2010 @ 21:05
Depuis mon dernier message, j'ai eu le temps de bidouiller et tester n

Les ordinateurs ont leur adresses automatiquement, donc j'ai modifié dans la colonne correspondante de WakeOnLAN, j'ai mis les noms DNS, ce qui est plus juste que des adresses IP (qui changent tous les 3 jours (dans mon cas), cela faussait certainement le ping (en tout cas, cela s'est effectivement vérifié).
D'ailleurs, pourrait-on avoir la possibilité d'obtenir les noms DNS comme c'est le cas avec les adresses IP (au moment de l'ajout d'une machine, c'est possible seulement manuellement) dans une future version ?
Ensuite j'ai toujours une (ou deux je sais même plus d) machine(s) qui ne démarre pas en WOL, j'ai bien pensé aux paramétrages que tu as indiqué. J'ai comparé avec une même machine (qui, elle, démarre bien) niveau BIOS et carte réseau, mais tout est OK. Encore un mystère de l'informatique comme je dis de temps à autre...

Enfin, concernant le message "paquet envoyé..." je ne l'avais tout simplement pas remarqué, il est bien caché le bougre ! Je te parlais seulement du message qui apparaît dans une boîte et qui indique qu'un paquet magique est envoyé à chaque machine sélectionnée...ce message réapparait, mais en haut à droite de la fenêtre principale du logiciel, si on tente un autre réveil.

En espérant avoir été clair^^
Merci

 
[réponse de damien, le 22/01/2010 à 21h40]

Il est effectivement préférable, dans le cas d'un réseau en DHCP, d'utiliser les noms FQDN (Full Qualified Domain Name ou noms DNS).

Quant à surcharger la fenêtre de propriétés des machines en ajoutant un bouton supplémentaire, je ne suis pas pour. Autant la recherche de l'IP et de la MAC se justifient car on peut ne pas les avoir sous la main, autant il n'est pas compliqué de saisir l'adresse DNS quand on connait le nom NetBIOS. Faut quand même pas pousser ! wink

Pour ce qui est de la fenêtre de traitement, il y a un paramètre pour que celle-ci apparaisse systématiquement ou uniquement en cas de sélection de plusieurs machines ("N'afficher la fenêtre de traitement qu'en cas de traitement multiple"). Mais dans tous les cas, le message signalant l'envoi du paquet magique s'affiche quelques secondes à l'extrémité droite de la barre de menu.