Ce site dans votre langue

French English Afrikaans Albanian Amharic Arab Armenian Azerbaijan Basque 
Belarusian Bengali Bosnian Bulgarian Burmese Catalan Cebuano Chichewa Chinese (Simplified) 
Chinese (Traditional) Cingalais Corsica Croatian Czech Danish Dutch Esperanto Estonian 
Finnish Gaelic (Scotland) Georgian German Greek Haitian creole Hawaiian Hebrew Hindi 
Hungarian Icelandic Igbo Indonesian Irish Italian Japanese Kazakhstan Khmer 
Kirghiz Korean Kurdish Laotian Latvian Lithuanian Luxemburgish Macedonian Malaysian 
Maltese Mongolian Nepalese Norwegian Polish Portuguese Romanian Russian Serbian 
Slovak Slovenian Spanish Swahili Swedish Tagalog Tajikistan Thai Turkish 
Ukrainian Uzbek Vietnamese 

Plugin TranslatorBox par Dipisoft
Merci à Google Traduction

Recherche sur ce site
Recherche sur ce site
Dons / Contributions

A titre d'information, l'hébergement et le nom de domaine de ce site me coûtent 87€/an, montant non atteint en dons ces 2 dernières années.

Alors si vous souhaitez participer...

... vous rejoindrez ainsi la

 ↑  
Newsletter
Pour avoir des nouvelles de ce site, inscrivez-vous à notre Newsletter.
TPapwR
Recopier le code :
485 Abonnés
Traductions des logiciels

La traduction d'un des logiciels est inexacte ?


Le logiciel que vous utilisez n'est pas traduit dans votre langue ?


Vous êtes en mesure d'apporter votre aide à Dipisoft ?


Alors rendez-vous sur la page des fichiers de langues et rejoignez la liste des contributeurs !
Visites

 1906682 visites

 20 visiteurs en ligne

Réseaux sociaux

lanalertcenter01.png lanalertcenter02.png

Ce logiciel a pour but d'aider les admins à paraître moins "bébète" face à leurs utilisateurs en cas de panne serveur/réseau ! rolleyes

En effet, je suis admin depuis de nombreuses années et j'ai souvent été confronté à la désagréable situation où, absorbé par des taches diverses et variées, je ne me suis pas aperçu qu'un de mes serveurs (ou le réseau local) était "tombé" en carafe... et quand cela arrive, je trouve gênant et frustrant que ce soit un "simple" utilisateur qui vienne le signaler !

C'est donc pour éviter ce genre de situation que mes petits doigts boudinés ont caressé les touches de mon clavier des heures durant pour donner naissance à LanAlertCenter (précédemment nommé Pang). Cet outil a donc pour mission de surveiller des machines définies et d'alerter l'admin rapidement en cas de problème...

Principales fonctionnalités :

  • 7 analyses possibles :
    • test de réponse à la commande ping,
    • test de présence/accessibilité d'un partage nommé,
    • test d'accessibilité base de données (tous types : Oracle, mySql, PostgreSQL, Informix, Sybase, SQL-Server, MS-Access, Interbase, DB2, etc...),
    • test de l'état d'une imprimante réseau (compatible avec le protocole SNMP),
    • test de l'état d'un service,
    • test de la présence d'un processus,
    • test de l'espace disque libre (en valeur absolue ou en pourcentage).
  • possibilité de définir une fréquence d'analyse différente pour chaque machine surveillée,
  • possibilité de définir des périodes d'exclusion d'analyse (jour et heure),
  • possibilité de définir des actions à déclencher en cas de réponse/non réponse,
  • possibilité de choisir le mode de reporting des erreurs (popup, mail, msg, systray, journal des événements du système, fichier de journalisation, etc.),
  • et bien d'autres choses à découvrir en testant LanAlertCenter ! wink


ASTUCE : il est possible d'ajouter le paramètre /run dans le raccourci qui lance LanAlertCenter ; cette option permet de démarrer le traitement automatiquement à l'ouverture du logiciel. Cela peut être intéressant notamment si vous placez le raccourci dans le groupe Démarrage de votre menu Démarrer...

ATTENTION :

  • la mise en oeuvre du test d'accessibilité à une base de données nécessite que la couche Odbc32 et le pilote correspondant au SGBD concerné (Oracle, mySql, PostGreSQL, etc.) soient installés...
  Télécharger ce logiciel (version installeur)
  Télécharger ce logiciel (version portable ZIP) Note importante aux utilisateurs des versions portables

Date de création : 21/02/2005 @ 14:15
Dernière modification : 06/02/2017 @ 20:49
Catégorie : - Aide à l'administration
Page lue 148483 fois


Réactions à cet article

Réaction n°129 

par Stef le 01/02/2009 @ 16:59
Je suis vraiment un gros naze !

Et toi une bête (ou tu est plus reveillé que moi, ceci étant dit pour moins me dévaloriser !).

Bon, ben je m'en vais promener madame et les chtit' n'enfants, avant qu'il pleuve ou qu'il fasse nuit (ou les deux).

A+, camarade, et encore merci !
S


[réponse de damien, le 01/02/2009 à 17h01]
Bonne ballade !

Réaction n°128 

par Stef le 01/02/2009 @ 16:52
Ok, bien vu, le coup du ping en anglais !

MAIS : dès que je touche à ce foutu ping.exe, un process me le recrée automatiquement à la version 2003.....

Une idée ?

S

[réponse de damien, le 01/02/2009 à 16h55]
Oui, j'ai dit qu'il fallait le coller dans le dossier de l'appli, pas dans System32 !

Réaction n°127 

par Stef le 01/02/2009 @ 16:35
Waou !

Quelle réactivité !

Je vois que tu as aussi un temps pourri... et pas de femme pour te dire de réparer le lave-vaisselle ou le lustre de la salle.....

Bon, ok, la mienne est dans le canapé avec un bouquin.... et elle a oublié le "reste-à-faire", donc j'en profite.

Je teste ca de suite.
Reste un pb : l'envoi de mail : avec  et sans les authentifications, ca march'pô...
T'aurais pas un tuyau ? (je suis chez Free)

A+
S


[réponse de damien, le 01/02/2009 à 16h48]
Ma femme me met aussi (et hélas !) au boulot ! Tu aurais écrit ce matin j'étais en courses, et en début d'après-midi en train de remplacer la literie de notre chambre. Donc côté réactivité je suis comme tout le monde, je n'ai pas encore tenté la greffe d'un chipset avec wifi pour rester connecté en permanence ! biggrin

Pour l'envoi des mails, il faut en fait ne pas remplir les champs login et password car l'authentification ne fonctionne pas (c'était une expérimentation car je ne pouvais pas le tester de mon côté). Donc pas de soucis pour Free : il suffit de spécifier une adresse d'expéditeur @free.fr (sinon ça ne passe pas) et ce même si l'adresse est bidon...

Réaction n°126 

par Stef le 01/02/2009 @ 15:20
Bonjour, et bon anniversaire !

J'utilise de temps en temps ton logiciel lorsqu'une machine a "mal au ventre" chez moi, et j'ai tenté de l'installer sur un 2003 serveur.

Mais j'ai un pb, je n'obtiens pas de réponse au ping, y compris sur la boucle locale, alors que "ping" sous dos fonctionne.

J'ai pensé à un pb de compatibilité avec 2003, car je l'ai testé en mode compatibilité XP avec le même résultat, ce qui me fait penser qu'il y a en effet un pb de compat' du à certaines dll..........pb déjà rencontré avec des softs que je développe en VB5 (comme toi) et que j'ai eu le malheur de vouloir porter sous 2003.

Tu as un REX à ce sujet ?
S


[réponse de damien, le 01/02/2009 à 16h04]
Il existe effectivement quelques problèmes connus sous W2003 : ils sont tout simplement dus à la commande PING du DOS dont le résultat est retourné sous une forme très légèrement différente (ou en anglais, je ne me souviens plus) de celle de WinXP ou de WinME.

Le problème a été corrigé dans la dernière version (toujours non diffusée à ce jour), mais en attendant la prochaine mise à jour je conseille de récupérer le PING.EXE d'un XP
(ou de récupérer celui de ce fichier) et de le copier dans le dossier de l'appli. A noter que le problème concernait aussi IPScan32 et WakeOnLan mais qu'il a été corrigé dans les versions récentes.

Et merci pour mon anniv' ! wink

Réaction n°125 

par Guy le 11/01/2009 @ 23:39
Bonjour,

et meilleur vœux pour cette année.

Je viens de faire un tour dans les logs, pourrait-il y avoir une petite évolution qui permettrait de charger les logs dans un tableur par exemple et de pouvoir  les exploiter pour faire des stats.

Cordialement


[réponse de damien, le 12/01/2009 à 06h52]
On peut effectivement l'envisager pour une prochaine version... Enfin en attendant, rien ne t'empêche d'ouvrir les fichiers sous Excel ou Calc (OpenOffice) : les données sont séparées par un caractère TABulation.

Réaction n°124 

par Muso le 03/01/2009 @ 09:45
Bonjour,

Tout d'abord merci pour ce programme qui fonctionne bien.
Cependant j'ai une question je souhaite pinger une adresse dyndns
exemple : http://dyndnsadapah.dyndns.org/

que dois je rentrer dans la configuration de cette machine ?

en effet sous dos, je peux bien pinger cela me répond bien
"ping dyndnsadapah.dyndns.org"

par contre ton logiciel me met l'icône que j'ai choisi avec une croix rouge dessus
Est ce normal ??
Peux ton piguer des serveur situé derrière Dyndns ?


[réponse de damien, le 03/01/2009 à 11h26]
L'adresse à indiquer dans l'appli est la même que celle que tu utilises dans la commande ping.

La croix rouge indique que la machine n'a pas été analysée (en fonction de ce que tu as configuré dans la partie "exclusion"), et non qu'elle ne répond pas. Cette erreur est fréquemment commise, j'en viens à me demander si ma logique ne va pas à l'encontre de celle du commun des mortels ! mad

Les cases à cocher lundi, mardi... jusqu'à dimanche sont destinées à indiquer les jours où la machine NE DOIT PAS être analysée. Idem pour les deux zones de texte "plage horaire" qui servent à indiquer une période durant laquelle la machine en question sera ignorée (non analysée). Ces deux champs et les cases à cocher sont facultatifs.
Petite précision pour l'exclusion horaire : la première heure peut être supérieure à la seconde (23:55-00:05) dans le cas où l'exclusion est "à cheval" sur deux jours. Le résultat sera bien une exclusion de 10 minutes et non de 23h50 comme ce serait le cas en spécifiant 00:05-23:55...

J'espère que c'est plus clair comme ça ?

Réaction n°123 

par richard le 04/12/2008 @ 23:44

Bonjour,

j'utilise LanAlertCenter pour surveiler des routers. Votre logiciel me donne entiére satisfaction et j'en profite pour vous remercier.

Voici mes questions :

1°/ Je n'arrive pas à transmettre de message à partir du dispositif SMTP. Je l'ai initialisé avec les parametres de ma messagerie personnelle (smtp.laposte.net). Est ce le serveur de LA POSTE qui empeche la transmission ou ai-je oublié de cocher une option dans votre outil ? D'autre part je n'arrive pas à supprimer les informations dans ce formulaire, comment faire ? où sont-elles enregistrées ?

2°/ J'ai créé des dossiers dans lesquel j'y ai mis tous les routers d'un même site. Le dossier passe rouge lorsqu'un des routers est défaillant. Tant que ce router n'est pas rétabli il est impossible de visualiser un incident sur un autre router du même dossier sans l'ouvrir. Comment peut-on être averti qu'un autre router du même dossier est défaillant sans ouvrir le dossier ?

@ bientôt, Richard BLAUT



[réponse de damien, le 05/12/2008 à 09h25]

Pour commencer j'ai déplacé ton message, qui n'avait pas sa place dans le livre d'or, vers l'article LanAlertCenter. Merci de veiller à poster à l'emplacement le plus adapté : histoire que les autres visiteurs s'y retrouvent, mais aussi pour m'éviter du boulot inutile.

J'en viens à tes questions.

1°/ La première chose à savoir, même si ce n'est pas spécifié dans l'outil (mea culpa), c'est qu'il NE FAUT PAS renseigner les champs USERNAME et PASSWORD si le serveur SMTP ne nécessite pas une connexion authentifiée. Et dans la quasi totalité des cas, c'est ça la source du problème... Ou alors il s'agit d'un SMTP sécurisé et tu as omis de renseigner ces champs.

Si tout est OK de ce côté, il faut chercher ailleurs : peut-être ton firewall et/ou antivirus interdit-il l'utilisation du port 25 pour les applis non référencées ? C'était le cas à mon boulot où McAfee VirusScan était configuré ainsi... Recontacte-moi si malgré ces pistes tu ne parviens toujours pas au résultat escompté

2°/ Quand tu dis qu'il est "impossible de visualiser un incident sur un autre routeur", je ne suis pas d'accord : certes, l'icone ne change pas (il n'est pas 2x plus rouge ! biggrin) mais les alertes sélectionnées sont bien traitées. Par exemple, si tu as coché "informer par fenêtre popup", le second dysfonctionnement détecté entrainera bien l'apparition du popup. Idem pour les alertes mail et net send. Je ne vois pas ce que je peux faire de plus... 

J'espère que ça répond à tes questions.

 


Réaction n°122 

par Samy le 04/12/2008 @ 19:06
Bonjour Damien et toutes mes félicitations pour ton soft. Vivement la prochaine version...
Juste une petite question:
J'aimerai avoir des informations sur la façon dont sont implémentés
- le ping par API
- le ping par WMI.
Je m'explique, j'utilise LanAlertCenter 3.04 pour monitorer plusieurs serveurs repartis sur plusieurs sites géographiques.
Nous avons actuellement un projet de réorganisation du réseau global intersite. Un site pilote a été migré. Mais depuis la migration je me suis aperçu que le ping par API qui était réglé dans "mon" LanAlertCenter n'atteignait plus les serveurs de ce site. Par contre pas de problème avec ping par WMI ni bien sur avec un ping classique en ligne de commande.
Cela a donc fait émergé une inquiétude sur cette migration, et nous nous demandons si certaines applications ne pourraient pas être impactées.
C'est pourquoi je demande ces renseignements.
Merci beaucoup et bonne continuation dans tes projets.
Sam.


[réponse de damien, le 05/12/2008 à 10h46]

Comme son nom l'indique, la méthode "ping API" utilise des APIs de Windows :

 - WSAStartup (de wsock32.dll) pour ouvrir un socket,

 - GetHostByName (de wsock32.dll) pour récupérer l'IP, dans le cas où l'utilisateur a spécifié un nom NetBIOS/DNS

 - IcmpCreateFile (de icmp.dll) pour créer le handle ICMP

 - IcmpSendEcho (de icmp.dll) pour émettre le "ping" et attendre la réponse

 - IcmpCloseHandle (de icmp.dll) pour fermer le handle ICMP

 - WSACleanup (de Wsock32.dll) pour respectivement ouvrir et fermer le socket

Voilà pour la technique. Personnellement, je n'ai que très peu utilisé cette méthode, certes très rapide, mais qui manque à mon sens de fiabilité. D'ailleurs elle disparaîtra probablement dans la prochaine version. En attendant, je déconseille de l'utiliser.

La méthode WMI est nettement plus fiable et infiniment plus simple à mettre en oeuvre : il suffit de lancer une requête "SELECT * FROM Win32_PingStatus WHERE Address = ADDR", où ADDR représente directement la valeur saisie par l'utilisateur (qu'il s'agisse d'une adresse IP ou d'un nom NetBIOS/DNS). Le résultat est ensuite récupéré dans .StatusCode et .ResponseTime... simple et efficace, mais nécessite une machine dotée de WMI, ce qui est le cas avec les OS récents.

Personnellement, je préfère pourtant utiliser la méthode "ping DOS" qui fait un appel à la bonne vieille commande PING du DOS. Le traitement du résultat est certes plus complexe, mais il est très fiable. Elle présente en outre l'avantage de rendre la main plus rapidement que les deux autres méthodes (qui "freezent" l'appli quelques secondes) dans certains cas où l'adresse testée est erronée.


Je serais donc tenté de te dire de ne pas trop t'inquiéter pour tes autres applis...


Réaction n°121 

par macgor le 21/11/2008 @ 10:50
Encore une fois, je le redis, je suis FAN !!

Petite question toutefois, je surveille des services sur plusieurs serveurs... Et surprise, sur certains j'y arrive sans soucis, mais d'autres, j'ai une erreur : "Impossible d'accéder à la liste des services de la machine à distance"

Alors qu'elles sont configurées à l'identique (serveur Citrix), meme niveau de SP, Update...

Comment faire pour faire un test d'accès simple sur les services (un script vbs, wmi ??)

Merci d'avance (oui je sais j'en demande beaucoup)


[réponse de damien, le 21/11/2008 à 18h07]
Si tu obtiens un message d'erreur sur certaines machines et pas sur d'autres, c'est inévitablement qu'il doit y avoir une différence de config ou de droits...

Pour tester l'accessibilité à la liste des services en WMI, voici un petit exemple (en VbScript) :

Fichier Services.vbs
    Option Explicit
    Dim objLocator, objWMIService
    Dim colResultat, elm
    Dim strMachine, strLogin, strPass
    Dim strListe

    On Error Resume Next

    strMachine = "."
    strLogin = ""
    strPass = ""

    Set objLocator = CreateObject("WbemScripting.SWbemLocator")
    Set objWMIService = objLocator.ConnectServer(strMachine, "rootcimv2", strLogin, strPass)

    If Err.Number = 0 Then
        Set colResultat = objWMIService.ExecQuery("Select * from Win32_Service", , 48)
        For Each elm In colResultat
            If strListe <> "" Then strListe = strListe & ", "
            strListe = strListe & elm.Name
        Next
      
        MsgBox strListe, vbInformation, strMachine
    Else
        MsgBox "Erreur rencontrée : " & Err.Description, vbCritical, "Erreur"
    End If

Je précise au passage que LanAlertCenter n'utilise pas WMI pour accéder à la liste des services, mais des API (OpenSCManager et EnumServicesStatus notamment). Il est probable que je passe à WMI dans la prochaine version ou que j'offre la possibilité de choisir... je me tâte encore. wink

Réaction n°120 

par julien le 15/10/2008 @ 10:20
Bonjour,

j'utilise depuis longtemps lanalertcenter et j'en suis très content.
Depuis Hier, l'envoi des mails ne fonctionne plus,  je veux faire des tests dans la config de lanalercenter et ca me provoque une erreur et ca ferme l'application:
Erreur d'exécution '430':
La classe ne gère pas Automation

Cependant, la config du PC n'a pas été changé et j'ai réinstallé le soft sans succès du coté des mails.

Cdlt,

JD.

[réponse de damien, le 20/10/2008 à 16h04]
Désolé pour le retard de ma réponse : ma connexion Internet vient tout juste d'être rétablie alors qu'elle était HS depuis 1 semaine... cry

Avez-vous trouvé une explication et réglé le problème depuis votre message ? Je penche pour le remplacement d'un des fichiers systèmes. Avez-vous installé quelque chose de particulier avant de constater l'erreur ? Avez-vous tenté une restauration du système à une date antérieure ?

Réaction n°119 

par Julbuttt le 09/10/2008 @ 11:59
Bonjour,

une petite question sur l'utilisation:
Comment fait-t-on pour que l'icône en barre des taches (barre en bas à gauche) s'enlève automatiquement car à chaque fois que le programme est lancée, après le traitement, l'icone (feu tricolore) reste , je suis obligé de passer ma souris dessus pour qu'elle disparaisse, aurait-il une astuce pour l'enlever automatiquement?

D'avance, merci.

Cdlt,

DJ.

[réponse de damien, le 09/10/2008 à 12h39]
En principe, l'icone de la systray disparaît automatiquement quand vous rouvrez la console (clic droit sur l'icone, puis option "restaurer"). Si ce n'est pas le cas, c'est que l'appli n'a pas été fermée "proprement"... frown

Votre machine tourne sous quel OS ? On ne sait jamais, peut-être y a-t-il un bug. En tout cas, ça fonctionne bien sous XP...

Réaction n°118 

par Pierre le 06/10/2008 @ 14:34

Excellent ce programme ! Exactement ce qu'il me fallait.

Par contre, il serait sympa de préciser (et souligner) dans la description ci-dessus

que les champs nom utilisateur / mot de passe ne doivent pas être renseignés pour

l'envoi des notifications par mail.

Cela eviterait de mettre en doute les fonctionnalités du programme et de devoir

chercher dans la liste des réactions

Merci.l

 

[réponse de damien, le 06/10/2008 à 15h07]
En effet, désolé pour la longue recherche. confused
Enfin je suis sur qu'elle vous aura permis de découvrir d'autres trucs utiles ! tongue

L'information est ajoutée dans l'article pour les prochains lecteurs. wink

 


Réaction n°117 

par Bruno le 05/10/2008 @ 03:49

Bonjour,

Je voudrais vous suggérer quelques améliorations pour LanAlertCenter :

- N'envoyer d'alerte qu'en cas de plusieurs tests d'affilés en défaut (2 ou réglable) pour éviter d'être alerté lors d'une courte interruption de connexion qui se passe juste au moment du test.

- Possibilité de personnaliser les alertes mail pour pouvoir les adapter à l'application et aux limitations d'affichage à l'arrivée, par exemple un MMS sur un écran de tél portable petit et qui ne lit pas les accents (par exemple vos messages sur le mien :

"ne r pond plus (Timeout)"

"r pond  nouveau (OK (84ms))"

Cordialement.
 

[réponse de damien, le 05/10/2008 à 10h10]
Tout d'abord, j'ai transformé votre post (du livre d'or) en réaction à l'article sur LanAlertCenter puisqu'il concerne exclusivement cet outil. Merci de veiller à poster au bon endroit car dans le cas contraire ça nécessite de faire des manipulations dans plusieurs fichiers (il n'y a pas de fonctionnalité de ce genre dans la zone d'administration de GuppY). Avec le risque de corrompre la base... rolleyes

S'agissant de vos suggestions :

 - il est prévu que je modifie le fonctionnement actuel d'envoi des mails pour le rapprocher de celui des actions : cela comprend donc la possibilité de définir le nombre de non-réponses qui conditionneront les envois de mails.

 - je n'avais pas envisagé de permettre de personnaliser les alertes mais cette idée me va bien... je la note ! wink

 - pour ce qui est des accents, il est prévu que la configuration SMTP soit enrichie : sélection du format des mails (text ou html, charset notamment).


Réaction n°116 

par Pascal le 04/10/2008 @ 22:08

Super comme logiciel, toutes mes félicitaions

merci beaucoup.

Une petite sugestion (si vous ne l'aviez pas déjà eue), pourriez vous intégrer des variable que l'on pourrai utiliser dans l'objet de l'alerte pas courriel, par exemple Nom du serveur et heure de l'alerte (en effet les heure des serveurs de messagerie sont parfois en heure GMT).

Par avance merci.
 

[réponse de damien, le 05/10/2008 à 09h47]
J'avais effectivement prévu d'intégrer quelques variables (ip, nom machine, type de surveillance) mais je n'avais pas pensé à ajouter l'heure du défaut... merci de la suggestion ! wink


Réaction n°115 

par Rico le 04/10/2008 @ 16:40
Salut Damien

Je cherchai un logiciel pour surveiller une machine, donc j'ai pensez a ton logiciel.

Il me manque une option, serait il possible de l'integrer.

En faite je cherche a scanner un port tcp/ip, et que LanAlertCenter me previenne quand il est ouvert.

Sinon super travail, t'es outils sont très pratique.

Rico®


[réponse de damien, le 04/10/2008 à 17h44]
Cette fonction est intégrée (depuis pas mal de temps déjà) dans la prochaine version qui n'est pas encore dispo... viens la voir à l'occasion ! wink

Réaction n°114 

par JB le 23/09/2008 @ 08:21
Bonjour,

Suite a un petit problème ce matin, il a fallut que je vérifie que tous mes équipements étais bien UP.
La solution : faire "arrêter" puis  "démarrer" ... un petit bouton "tout vérifier" ce serais super bien ;)

Encore merci.


[réponse de damien, le 23/09/2008 à 22h01]
Demande déjà formulée, mais tu as raison d'enfoncer le clou ! biggrinwink

Réaction n°113 

par Oots le 15/08/2008 @ 13:27

Bonjour,

Merci pour ce logiciel très utile de surveillance qui semble avoir fait beaucoup d'heureux.

D'une nature feignante, je me demandai s'il n'était pas possible de faire une détection automatique des machines connectées à un réseau en définissant une plage d'adresse de balayage. Du genre, scanner de "192.168.200.000" à "192.168.200.255" et définir le type, ordinateur ou imprimante, et de les ajouter à la fenêtre graphique?

Je précise que je n'ai que des notions limitées en informatique, cette suggestion est peut être absurde techniquement n

Oots

 

[réponse de damien, le 22/08/2008 à 12h38]
Je ne souhaite pas inclure de fonction de scan de plage d'IP à LanAlertCenter : il faut utiliser IPScan32 pour ça. wink

J'ai toutefois fait quelques recherches pour implémenter une fonction de recherche automatique via le protocole "bonjour" d'Apple, mais sans succès pour les machines fonctionnant sous Windows : seules les imprimantes semblent y répondre pour l'instant... je conserve mes bouts de code de test pour l'avenir. frown


Réaction n°112 

par Jack le 09/07/2008 @ 14:52

Bonjour Mr PONNELLE,

Tout d'abord un grand merci et un grand bravo pour vos outils et en particulier LanAlertCenter.

Execellent outil très intuitif et très puissant qui va beaucoup m'aider dans ma gestion quotidienne professionnelle.

Seulement, je me permet, si c'est possible bien sur, de vous suggérer une amélioration. J'utilise l'outil pour surveiller tout un tas d'équipements (routeurs, relais SMTP, firewall, ...) soit à peu près 200 équipements. J'ai positionné des alertes à la fois sur réponse et sur non réponse (pour avoir l'info quand un équipement tombe et quand il revient à la vie). L'outil est positionné sur 1 serveur et il vit ainsi tout seul. Le seul pb est que, pour savoir si l'outil est tjs "vivant" je l'arrête et le redemarre 2 fois par jour et lui demande un rapport. L'ennui est que dans ce rapport j'ai une longue liste d'équipement OK et qqs équipements down. Les OK bien sur ne m'interesse pas dans ces 2 rapports quotidiens. Donc 2 questions : Est-il possible que l'outil dise "Hello je suis bien la à cet heure-ci et voici la liste des équipement KO" OU, que l'on puisse choisir quel résumé l'on veut avoir quand on redémarre l'outil (équipement OK et/ou que équipement KO).

Si c'est possible çà serait le TOP !!!

Merci en tout cas pour votre attention. Cordialement.

 

[réponse de damien, le 09/07/2008 à 18h20]

Merci pour vos compliments, pour commencer... c'est toujours très plaisant. wink

Je ne comprends pas trop l'utilité d'arrêter/redémarrer le soft en dehors de modifier/ajouter/supprimer des machines ou modifier la config. Cela arrive-t-il si souvent qu'il se plante pour en arriver là ? La prochaine version devrait intégrer un mini serveur web pour consulter l'état des machines - et de l'appli - quand celle-ci n'est pas installée en local. Je pense que cela devrait régler partiellement le problème, non ?

En ce qui concerne l'autre sujet que vous évoquez, à savoir "la longue liste d'équipements OK" à chaque redémarrage de l'analyse, ceci peut être inhibé en décochant la case "Alertes et actions effectives à la première analyse" dans la rubrique "Général" de la config du programme. Par contre, le traitement est actuellement le même si les machines sont OK ou non : les machines en erreur sont bien représentées en rouge mais aucune ligne n'en faisant référence n'est versée au fichier log dans ce cas. Si besoin, je peux éventuellement ajouter une option pour différencier le traitement des machines selon si elles sont OK ou non... à voir.

Cette réponse vous convient-elle ?


Réaction n°111 

par iutgtr2 le 16/06/2008 @ 09:42

Bonjour,

Merci pour votre soft qui est vraiment sympa et utile. Cependant, cette version 3.0.4 a tendance à planter et devenir inacccessible quand un serveur de base de données (Oracle dans mon cas) ne répond plus (test avec méthode base de données). LanAlertCenter est installé sur Windows XP SP3, mais j'avais le même problème sur XP SP2 et 2000 Pro. Les bases testées sont des Oracle 9 pour la plupart.
Merci à vous
Cordialement

Richard


[réponse de damien, le 16/06/2008 à 13h43]

En effet, il arrive parfois que l'appli freeze dans certains cas d'inaccessibilité de base de données. Le problème ne vient pas directement de LanAlertCenter puisque celui-ci non plus ne "récupère pas la main". Il peut s'agir de n'importe quel composant de la chaîne d'accès aux données : RDO, ODBC, driver, etc...

Je n'ai pas de piste pour le moment. Désolé. frown


Réaction n°110 

par o1ivier le 29/05/2008 @ 20:54

Ha effectivement!
Le rendez vous cez l'ophtalmo est prisk

j'ai honte ddd

Olivier

 

[réponse de damien, le 29/05/2008 à 21h00]

Pas de soucis ! wink